Rockpi4c cannot boot from emmc

I bought the brandnew rockpi4c, and try to boot from emmc.(Android9)
But, it cannot boot up. and led :green ON , blue blink twice (/ 1second).
I tried the SPI flash

  • sudo rkdeveloptool db /path/to/rk3399_loader_spinor_v1.15.114.bin

    output: Downloading bootloader succeeded.

  • sudo rkdeveloptool wl 0 /path/to/rockpi4c-uboot-trust-spi_2017.09-2692-gdf20631bd8_20200824.img

    output: Write LBA from file (100%)

  • reboot the rockpi4c (maskrom mode, )
    sudo rkdeveloptool rd

will output: Reset Device Failed. <<<< ???

I tried this process several time, but,
What should i do?

I missundstood.
“Reboot the device” is just exec the command “sudo rkdeveloptool rd”, it is not power on/off of rockpi4.
As the result of this action, “Reset Device OK” is displayed.
But, still now, rockpi4 cannot boot from emmc.
Plaese help me.

can you test the latest android 10 with the guide from this thread:

Thanks for your support.
Yesterday, I confirmed 4/5 pcs of rockpi4c coud boot up from emmc(Android 10).
But, this 1/5 pcs of rocpi4c cannot boot still now.
I followed your guide (windows), but I cannot load the downloaded image file.

The process is followings.

  1. Boot rockpi4c in maskrom mode.
  2. Flash the fw by AndroidToolsV2.3. (Windows)

Tonight, I cannot erase the SPI by windows tool by this problem.
But I tried to erase the SPI using linux pc (raspberry-pi).
And I can success to erase the spi.
After that, I can success to boot the Android 10.
Thank you.

1 Like