Rock5 does not work on most PD power supplies

well the original power supply does not cut it. powercycling all the time. updated SPI and Loader as mentioned in the PD thread. Still cycling. When i attach it with the usbc2usbc cable to my laptop as supply it works like a charm. I would have guessed it that the original ps and cable was tested and working well …

bummer …

My SBC was posted on 20th of October from Allnet China and already arrived with the latest firmware (v1.08.111 @ 2022-09-29 … checked on UART).
The ordered 65W power supply worked for me out of the box but I also had problem with other PD sources (dock stations, Lenovo 65W PSU). Nevertheless it also worked with Mi Power Bank 3 Pro. This was with the stock Debian image.

Then I installed Armbian and it works with (almost) everything including an LG 27UD69P monitor.

BTW, the fixed 12V input also works see my other post.

Thank you, for what it’s worth Armbian negotiates PD at the highest available for the power supply

Adapter: rk3x-i2c
in0:          20.00 V  (min = +20.00 V, max = +20.00 V)
curr1:         3.25 A  (max =  +3.25 A)

However booting to nVME with armbian doesn’t appear to be possible without an sd card right now.

Yeah that might be a problem from what others where saying.

I was sure someone was saying 20v could be too high as the accompany caps are 16v but lost in the forum as can not find it and maybe I was dreaming!?
My memory sucks so maybe it was something else.

[edit] found it yep my mem rockpi4

Not the case for ROCK 5B. The ROCK 5B is designed considering full PD voltages up to 20V.

1 Like

Yeah I did say in the edit, dunno why it stuck in my head as only really speed reading much of the PD woes.

Then there is still a software issue, I can’t use any PD power plug. I need to power the board with at least ~7V 2.5A in peak to get is working stable.

With this exact same board revision (v1.42 2022.08.29), my 3 PD adapters failed to power the rock 5B, negociation fails with infinite loop (Allnet 65W, Asus 65W and no name 65W), all having to move to 9V or higher for more than 15W and it is probably part of the explanation. With the Allnet PD654A charger bought fro the rock4B+, I tried both USB-A and C, but 5V is limited to 3A and this is here too low.

I did not think about it at first, but while ready these posts, I realized I had two unused smartphone chargers and the one from OnePlus Nord 2 is a simple 5V 2-6 A adapter… I crossed the fingers and tried… YEESSS!

If You have spare 5V smartphone adapter capable of 5 or 6A, not a PD compliant one, so with only 5V option, You may give it a try as it worked for me. FYI, I booted from a SanDisk Ultra 32 GB SD card.

Important: once upgraded (sudo apt-get update), most PDs are supported and boot correctly, although not all chargers while it is ok with Rock pi 4B+

You can use a Pi 5v dumb usb-c to get it to boot as there is the weird thing on new images you will hit on 1st boot it will not like some PD.
Plug in any dumb psu and boot, shutdown swap to pd and you are prob ok.
I guess its the 5.1v 3amp of the Pi PSU that has given no problem with stability for me with x2 boards tested.

I’ve added the “Baseus 65W GaN3 Pro CCGAN65-1ACC” to the wiki.

USB-C1 Port:
The 20V/2.25A is ONLY available on this port, and the Rock5B was stable for hours on this port running “stress -c 8”. Setup includes fan, 16GB eMMC and 1TB NVME drive, network but no display attached, with BIGcore temps 56.4°C (26°C ambient).

USB-C2 Port
This port negotiates at 12V/1.75A (iirc) but the Rock5B reboots under full load. However, seems good for simultaneous use of a Rock3A (passive heatsink, ecoPI PRO HP housing, 32GB eMMC, no NVME) with “stress -c 4” giving CPU temp 69.4°C .

Baseus “100W” cables were used for these tests.


Ordered mine as soon as possible, which meant October 19th from Allnetchina. And having the same issue with PD power supplies. Fortunately the board without any peripherals runs from regular old 5V USB power brick, my USB-C meter showing the board pulling around 1300mA peak and then running below 1A during normal configuration.

There have been a lot of posts and threads, and the “Debug Party” thread is now 613 posts long. Can anyone link directly a U-Boot image to fix the PD issue, with instructions?

The SPI Flash operation is described here:
There seem to be some late-september released files here:

So, what’s the order of operation, given I have a laptop with Linux on hand? Is it better to boot Rock5 with Linux and use the first dd method of flashing new SPI image? Or should I connect Rock5 as USB accessory (this is what I understand “Maskrom mode” is") and run rkdeveloptool, first with spl_loader and then spi_image files?

Yeah, wish there was good write up on this. 4 out of 6 of my Rock Pi’s are hanging in constant boot loading. Tried every plug I could find. Not going to order my other batch until I figure this one out as that’s already quite costly. They all have the date mentioned here in this thread. I mean the hw is frikking awesome on the 2 that’s working, just wish I could get past this hurdle.

i think both options would work well and the rk3588 cant be bricked so i think it is less hassle to do this with dd

1 Like

Totally bemused by the pd power and if you have purchased not much of bonus but just don’t by a PD unless you have one.
Just get a 12v 3amp as likely much cheaper and no problems.

No PD woes any more an 12v is the onboard bucks best voltage efficiency


after updating the SPI image, my Rock 5 is still boot looping, but not as often. I am not using it for the time being as I want a case first, so I can’t tell much more, but I think it is related to the software being used;

Given that Radxa said it is fine with up to 20V, I think you can use a PD(15V or 20V)-DC(5.5) cable + DC(5.5) to USB-C, or maybe you have laptop power supply leftover you can use them (mostly 19V) as well with proper USB-C adapter. Personally my intended application is to connect it directly to my Dell U2720Q’s USB-C(90W), so I will not try DC myself.

Tried and unfortunately there was no /dev/mtdblock0 on my system (Ubuntu Server 20.04). But it connected successfully in Maskrom mode so I did the SPI flash from my Linux laptop.
It does boot from one Baseus PD power brick, but still has 3-second reboot with my Anker and Sony PD bricks. So it’s a partial solution. Unless there’s something more that I should flash beyond
sudo rkdeveloptool db /path/to/rk3588_spl_loader_v1.08.111.bin
sudo rkdeveloptool wl 0 rock-5b-spi-image-g49da44e116d.img

boot it up with the working psu and run an update with:

sudo apt update && sudo apt upgrade

1 Like

Thank you, it helped!
It now works with all tested PD chargers, except Anker Powerport Atom PD 1 (my favourite travel brick, 30W PD up to 20V in a tiny and light package). It still works with Anker Nano II 65W, its sort-of successor, and all others I have tested, so I’m considering the current situation good enough.

Got one usb plug that works and now happily running my rock pi 5b’s. So happy with this board !!!

Edit spoke to soon 5/6 rock pi’s work. The last one is having trouble starting up even with the plug that got all the other ones to start. I am struggeling updating the cards as well manually with flash. No matter what plug I use and even following the procedures I get any connection to the flash software.

Any advice what next step to do to try to flash it or to get it booting somehow?

Finally found useful reply.