Rock pi s debian ftdi driver missing

hi, I am working on rock pi s with debian, we need to use ftdi device to get data from other hardware. by using lsusb, I can see the ftdi device is in the list, but there is no ttyUSB* shows in /dev/
does anyone have an idea how can I fix it?

By enabling, adding or porting a driver if not present in the kernel.

do you have detial about how to do that?

Make an image this way and enable what is missing:
What exactly is missing I don’t know from your post.

IMO. Just enable all FTDI related devices you find in the kernel config … perhaps stock Armbian already works for you OOB. Check that first.

Edit: I just saw this is about Rockpi S which is not supported by Armbian simple building procedure. Then manual way … Google for generic instructions and/or Radxa wiki.

If you want to use Armbian, as I did, you can use this branch from my repo: and build it (buster) with:

./ minimal BOARD=rockpi-s BRANCH=default KERNEL_ONLY=no BUILD_DESKTOP=no RELEASE=buster

It contains:

  • quite recent Armbian,
  • Rockchip kernel with Radxa’s and 4.4.192 patches
  • Rockchip u-boot with Radxa’s patches
  • u-boot patch to make LAN MAC address stable based on CPUID
  • almost all USB_SERIAL modules compiled :wink:
  • overclock to 1.3 GHz

I was going to bring Rock Pi S to Armbian but it has to be built from my custom repos for now :frowning:
Ayufan’s repos used by Armbian for rockchip64 builds are far behind Rockchip’s and do not have necessary commits to support RK3308.


I can build it, but it won’t run on board, only green light on, and plugin Ethernet cannot see shows in router side.

Can you try to connect serial console to it to check what the error is?
Console is on UART0 which is either on 8,10 (v1.1+) or 9,1 (v1.0) depending on the board version.

I will probably upload somewhere precompiled version soon.

nothing readable print out on 115200 bound rate

I was going to mention it - for Rockchip platform 1500000 is default baudrate.

still nothing print out. can you send me a image file and have a try?

Try this image, I have just booted it.

EDIT: One more mention, there is neither WiFi nor Bluetooth in this image.

rockpi login: root
 ____   ___   ____ _  __  ____  _   ____
|  _ \ / _ \ / ___| |/ / |  _ \(_) / ___|
| |_) | | | | |   | ' /  | |_) | | \___ \
|  _ <| |_| | |___| . \  |  __/| |  ___) |
|_| \_\\___/ \____|_|\_\ |_|   |_| |____/

Welcome to Debian Buster with Armbian Linux 4.4.192-rockchip64
System load:   0.13 0.20 0.09  	Up time:       2 min
Memory usage:  9 % of 425MB  	IP:
CPU temp:      34°C
Usage of /:    1% of 58G

root@rockpi:~# uname -a
Linux rockpi 4.4.192-rockchip64 #24 SMP PREEMPT Fri Oct 18 19:42:24 UTC 2019 aarch64 GNU/Linux
1 Like

thanks a lot. one more thing is what’s the password? I tried password, and it is not working

It is Armbian so default root password is: 1234 and you need to change it on first login (you can do it over ssh). At the same time you are forced to create a normal user with your own password.

I wonder what the problem was with the image built by you… Did you build it with Vagrant, Docker or bare metal?
Maybe I forgot to push something to the repo. I will try to build it in pristine environment to check.

I am using ubuntu to build it, I use the mini image from the armbian documents

Ok. Glad that the precompiled image worked :slight_smile:

Thank you a lot.

Hello, I use this image and have some trouble with shutdown.
1)install images on 6 pis
2)go to shutdown each pis, each pis have different command
sudo shutdown now
sudo shutdown -h now
sudo shutdown -P now
sudo poweroff
sudo halt -p
sudo init 0
everything was okay and work/
3) sudo apt update && sudo apt upgrade -y (in each pis)
4) sudo reboot (all pis)
5) do step 2 and pis dont work, ()

I have just tried the same procedure on one of my Rock Pi S with shutdown -h now and it: updated, upgraded, rebooted and is still successfully shutting down after the process.

One thing, although it should not matter at all IMHO, is that I used the latest image from this topic: Rock Pi S Armbian Buster minimal (pre-release). It is a bit newer than this one.

Thanks, for answer.
I install that image, and in newer version I havent this problem, but I have problem with docker.

Oh. I never optimised it for docker :wink: