Rock 5B maskrom mode not working

I’m having the same symptoms as the OP. In my case I was trying to boot with MMC, and can’t see any output on serial console (maybe it’s my UART cable). Green LED turned on, but blue LED never turned on after a long wait. eMMC was partitioned correctly as I can verify them on a Linux machine. Both Linux and Windows can’t see any devices in maskrom mode (green LED on).

I’ve contacted Allchina and they suggest this might be PD issue, so I tried a fixed voltage DC 12V 3A barrel jack to USB-C, but same symptoms as with PD…

I can confirm that PD is not working, I need to use a 9V constant Voltage Source, with lower then 6V it’s quite unstable. But the defect board, does not even response with 9V supply.

@jack, Do you have any Idea about the Board issue? Or an other suggestion?

My board have same symptom. I bought DP adaptor which support 9V and 3A.
But it doesn’t work with my Rock 5B.
Only Green LED turned on, no blue LED light and No Output.

@kimwida @n0x hi, have you been able to figure it out or RMA the board yet? Allchina has been ignoring my emails for few weeks…

It solved my problem.


Of note: the Rock 5B seems to prefer the SD card to the SPI for loading the initial boot loader. Because of this, the official Debian image written to an SD card will boot even with the SPI flash erased, and can be used to then recover the SPI.

(However, this also means that Debian booted from SD will not benefit from flashing a newer SPI image, as it never actually touches the SPI; execution jumps straight from the mask ROM to the boot loader on the SD card.)

1 Like

Without eMMC, without sd card, and empty spi flash, if plug the USB C to PC, no maskrom is detected, it’s means the board maybe defective. Please contact the distributor for an RMA.

I wrote Allnetchina and got the request to send it back, I will try this in two weeks, first I have to find a shipping parcel where the costs not half of a price of a new one.

I also have one out of a batch of 6 that’s failing pretty much anything. It blinks between green and blue. Have not been able to use maskrom correctly on it. Might be my fault I am still trying to make sure I Have a cable that I am 100% is USB 2.0.

Maskrom not working also for me. I press the maskrom button, keep it holded, connect the board with another pc with usb-c-to-usb-c cable, release button, and run the tools. No device found, ? try many times, same result.
I’m very disappointed by this board, only problems (I’m not alone by reading this forum), I can’t understand how such a product can be sold: buy the board, emmc, nvme, power supply, all the necessary to have this results… bah

@jack, is there any change to get JTAG running? And where are the pins?

The is missing the schematcis for the V1.42 Board.

1 Like

I’m having the same issue. Tried multiple power supplies including a bench supply which supplies through the USB C port, nothing, just boot loops using an SD card and debian image. There has to be a way to fix this without RMA’ing. What’s the cause of this issue?

ok, after some attempts maskrom now work

How high did you pull the voltage thru the usb-c port? I use min 9V. With 6 I as well saw reboot loops. But the mask rom is something different.

Did you something special?

12V, but this is a bench supply, so I can make it whatever I want. I really don’t think this is a power supply issue. In fact, this board was working, running for several days, and then I changed the image on the SD card and it just wouldn’t boot after that. I’ve tried pretty much any and every image available, including the new dietpi image.

not so special, I connect the board with my laptop by usb-c to usb-c

I have tried many images, for me the Armbian jammy seems to work and I will try to flash spi from there and boot from mvme

Out of my inital 6 from ALlnet China 5 worked after a lot fiddling with PD. One however I cannot get to boot and no maskrom mode either. I have followed the instructions to the tee an even ordered all the cables from AllnetChina recommended for rockpi5 and the red 2.0 USB c cable. Tried different computers as well for the receiving end and the different versions of the flash software (both 2.92 2.96 etc). Made sure to install the driver as well. Really at a wits end what to do. The card does boot up green but fails to go to blue.