Rock 5B maskrom mode not working

I have tried many images, for me the Armbian jammy seems to work and I will try to flash spi from there and boot from mvme

Out of my inital 6 from ALlnet China 5 worked after a lot fiddling with PD. One however I cannot get to boot and no maskrom mode either. I have followed the instructions to the tee an even ordered all the cables from AllnetChina recommended for rockpi5 and the red 2.0 USB c cable. Tried different computers as well for the receiving end and the different versions of the flash software (both 2.92 2.96 etc). Made sure to install the driver as well. Really at a wits end what to do. The card does boot up green but fails to go to blue.

Omg finally had to use the same plug in a lot of different USB slots but now it recognized the device and I could flash. To others in the thread dont give up if you got a 2.0 USB c and it boots with green light at least. Interestingly enough after flash I cant get it to work again in maskrom. I had to remove an unrecognized device in usb to get it to work first time. Will try now with updated flash if I can get it to boot.

Edit figured out how to get it consitantly into maskrom mode. I had to switch another usb device port then remove any fault usb device then plug in the rock pi 5b with button pressed into the spot the old device had. Then it would connect and I could erase all and reset device then do config + loader + image and flash it but after flash it would be gone from maskrom mode and show as bad usb device.

No luck in getting it to boot with micro sd and the debian distro so far.

The Installation documentation is all over the place. I was able to skip the downloading of the flash tools and the maskrom mode steps by just

  1. flashing debian to microSD
  2. boot rockpi from sd.
  3. log in rock/rock
  4. download the debian image & copy to /dev/nvme0
  5. download zero.img & the spi img & copy to /dev/mtdblock0
  6. shutdown and restart without microSD.
  7. Success.
    These instructions are in the installation docs, but aren’t so clear. Hopefully this helps. Sorry if this info is redundant as I just found this forum.
    Thanks
2 Likes

If you are on windows you have to install the “DriverAssistant” first for the rkdevtool to work. Hope this helps someone. Had me stuck for quite a while.

Wow! I really like the look of this board. It is the coolest looking single board computer in my opinion. With that. O M G! The software side of things are a disaster. None of the Android images available on Radxa wiki work with any of my many SD cards. Reborn OS and Debian boot from SD but I prefer Android. I know folks hate Android but that’s the interface I like so. It would be helpful if there were an accurate list of which sd cards work with what OS etc etc etc. oh well