Rock 5 Model B Unable to boot from M.2 NVMe

I flashed my M.2 NVME with the following images and is booting from NVMe:

  1. rock-5b-debian11-gnome-wayland-arm64-20220624-1200-gpt.img.xz
  2. rock-5b-debian-bullseye-xfce4-arm64-20221031-1558-gpt.img.xz

No issues in booting and is very fast.

But, when I tried to flash the M.2 NVMe with non-GPT images, it is not booting from NVM.2.

Is it possible to get GPT version of “rock-5b_debian_bullseye_kde_b33.img.xz” or how to flash M.2 using this image and make it boot from M.2.

Help is much appreciated.


There’s another thread basically asking the same question, looks like flashing the armbian SPI image should allow you to boot it.

The output from UART would help you get an answer that is useful in your case.

Thank you Biasio, I will try to flash Armbian SPI and let you know.

Eric, I am unable to login/boot the system. Can you let me know how can I get the UART output.

See the wiki: Rock5/dev/serial-console - Radxa Wiki

Thank you, flashing the Armbian SPI image worked. Thank you all for quick support.