Rock 3B custom cli build doesn't boot

I tried to build a custom image with rbuild tool based on the
description, but when i write the result image to the emmc card,
Rock 3B doesn’t boot.

Monitor doesn’t turn on, moreover none of the leds are lighting
even if there is a LAN cable attached to the LAN port. Based on this,
i came to the conclusion that the boot process failes at a very early

Here are the commands that i used to build the custom image:

./rbuild rock-3b bullseye cli


./rbuild rock-3b jammy cli

Could you please help what can the problem be?
@jack , @Stephen do you have any idea?
Thank you in advance!

On official image there is some problem with u-boot configuration, basically when You build image and do update then u-boot will ask what to do with config conflict. If You choose to stay with bundled one it will not boot after update, when force update is ok. I did not had time to debug this further but same thing happens on ROCK 4SE on recent builds so You need to be careful about this particular thing, especially when system is on eMMC :slight_smile:

He is build image from scratch, so the issue mentioned above should not effect him. There is however a long standing GPU driver issue, that causes CLI image for RK356X to fail to boot. I fixed it last week, but the kernel with this change is not published yet.

For now you have 2 options:

  1. build the kernel manually with bsp
  2. after the image is created, chroot into it, update modules.d to blacklist panfrost module, and update-initramfs -u.
1 Like

Thank you for your help! Glad to see someone on this forum who knows what he talks about. :+1: