Rock 3A not booting with any image

Hello there, I’ve been trying to get my ROCK 3A to boot for the past week.
I’ve tried both the 16GB eMMC module and various microSD cards, (4-64GB), as well as various USB-PD/QC chargers, all supporting 9V/3A and 12V/2A, and different cables.

What I do is as follows:

  1. Format eMMC/SD with SD Format Tool
  2. Flash the eMMC/SD with one of the official images (list below) using balenaEtcher (on macOS)
  3. Plug in HDMI and eMMC/SD to ROCK 3A
  4. Plug in USB-C power to ROCK 3A
  5. Wait for up to 60 min

…and nothing happens. The green light works, but the blue one never lights up, and there’s no picture on my HDMI monitor either.

This is the list of images I tried:

  • rock3a_debian_buster_xfce4_arm64_20211113_0127-gpt.img
  • rock3a_ubuntu_focal_server_arm64_20211113_0103-gpt.img
  • rock3a_ubuntu_focal_server_arm64_20210914_0859-gpt.img
  • rock3a_debian_buster_xfce4_arm64_20210914_0334-gpt.img
  • Armbian_21.11.0-trunk_Rock-3a_bullseye_legacy_4.19.193.img.xz

I would love to hear any feedback on what I might be potentially doing wrong or what I could try differently.
Please let me know if I can provide more details to help diagnose this

Can you try this? Short-circuit the FSPI_CLK pin and GND pin to make SPI Nor flash unavailable. See https://wiki.radxa.com/Rock3/FAQs

I tried, it doesn’t seem to work. Is there anything else I can try, or is my Rock 3 defective?

Have You tried to connect compatible uart console cable and view messages?
That helps a lot to see what is going on. Get any CH340 and try that.

If you have any uart console cable, you can check this guide.https://wiki.radxa.com/Rock3/dev/serial-console to setup serial tool.

Would you please do one more test? Check if maskrom device is detected. Please see part " Boot the board to maskrom mode" of https://wiki.radxa.com/Rock3/install/spi.

Hello,
I experienced exactly the the same problem. Used a SD card first, including the short-circuit as explained in the FAQ. Secondly I tried it using the eMMC module (had to purchase a USB3 enabled SD card converter, the build-in SD-card reader failed to connect the eMMC module).
Now Etcher is flashing the eMMC successfully, but still no boot: green led is flashing, blue isn’t. Tried that with and without the short-circuit without any changes.
According the video by Expaining Computers on Youtube, the short circuit is not required when using the eMMC.
I am not familiar with the debugging, don’t have a USB 3 male-male cable available.
Any suggestions?

I already have more than one rock3A board and for each all I had to do was to burn micro sd image and just plug right power source. With uart cable You will see all messages from first phase of boot where no hdmi output is available, this helps a lot to see what is going on, when some faulty image is burned it could give some output before it die. Some images have broken or limited hdmi output, not everything starts with blue lights.

I encourage you to get any cheap CH340G usb-uart cable - it cost as little as 1-2$ and work great. that helps a lot.

if You burned sd card with official images (try few) and none of them boots with blue led then it’s probably wrong power source. This is just guessing, but board should boot without anything else than power and SD card. Cellphone chargers (especially those pd-capable) sometimes are not working, also I could not connect rock3A to my power usb-c port on my lenovo with data cable - it try to sense what is there and cause boot loop. Also I got one or two chargers that were just not stable.

Good luck! :slight_smile:

I tried a few different cables, including USB C-C, USB C-A (3.0, data), and the USB-C cable included with the Macbook, to no avail.

I tried using different chargers, including the Macbook Type-C PD, an Aukey Type-C PD, Aukey QC 3.0, Blitzwolf PD, Blitzwolf QC 3.0, and a few Xiaomi PD/QC chargers as well, no change. I tried powering it directly from the Macbook too

I tried all available Ubuntu images, all Debian images, an Armbian image, both on microSD and eMMC. I used balenaEtcher.
At this point I’m wondering, is flashing the .img files sufficient, or do I need to flash U-Boot manually with dd?

In all cases, my CH340G shows no output. I tried switching RX/TX just to be sure but nothing.

Please remember that You can kill any board with electrostatic just by touching it. They can also be damaged in transport or have some issues. So far I had only one eMMC damaged, but it can always happen to any electronics. Was Your 3A working when it arrived?

For UART adapter - please find my post about them, there were some that stops board from booting, some displays garbage and some are not capable of 1500000 transfers. Board should send to UART some info before u-boot and system is loaded. I would try different adapter until it works on this or other decent RK board. UART gives more information before anything is on hdmi.

BTW: there was bug in uBoot that prevents from booting from anything else than eMMC, it is already fixed but You need to burn that to SPI. I don’t think that You have wrong version there right after shipping, that’s why I asked if it was working before?

Also You can post photo of Your setup. Maybe something is obviously wrong.

Hi,
Since you are talking about emmc, I wanted to ask you:
I bought a 16Gb emmc for Rock 3A, only the chips were marked FORESEE on the image, now I got a 16Gb emmc with MMY 5.1 mark.

Everything works perfectly, but I wanted to know if it is reliable, if you have had any of this type, I would not want to be scammed.

Thank you

I don’t have yet any eMMC from MMY, but they should be ok. So far the best result I got with sandisk. One foresee came damaged from allnet (and they did not answer to my complaint via email :frowning: later I managed to get it working by resoldering socket.
If this is emmc that You have it should be fast and reliable:
https://www.taiwantrade.com/products/detail.html?productid=1885491
Good luck! :slight_smile:

@james.kerber I think I was able to reproduce Your issue, right now I have two rock3a boards - one with working uart and one which can boot OS from eMMC and now from sd card. I’ll be trying to fix that, now looking what is different on those two. Do You have spare eMMC?

Yes, this is what I got MMY, and for now so good.


For SD I have always used the SanDisk A1 series, they are reliable and fast.

Thanks dominik