Raspberry Pi4 - New beta firmware and Quad Sata problem

Hello to all,

I have a Raspberry Pi 4, 4Gb version, and the complete Quad SATA kit.
Yesterday I installed the new Raspberry Pi 4 firmware in order to boot from USB (saw a lot of tutorials in Youtube).
On the procedure, it’s mentioned that we need to reboot the Raspberry several times.
After installing the new firmware and reboot the Raspberry, I noticed that the Top HAT LCD didn’t light up. Also, I noticed that the top fan was not working.
Thinking that something went wrong, I returned to my previous firmware and rebooted once again: no luck; the LCD and the fan didn’t work.
I then reinstalled HAT’s firmware (using the command curl -sL https://rock.sh/get-rockpi-sata | sudo -E bash -) and reboot again but still no fan nor LCD.
I can see that the HDD Leds, on the HAT, are working just fine and I noticed that the rockpi-sata.service was running. I tried to stop the service and start again, but no luck.

So, my question is: how can I debug why the LCD and the FAN are not working?

Please note that everything was working flawlessly and just upon the firmware upgrade I lost the LCD and FAN.
Also, I cannot format and install everything again because I am using my Raspberry as a NAS with a lot of Docker images with lot of services.

Hello Nimumo,

What will the following command output?

i2cdetect -y 1

Hello to all,

Sorry but had a very big problem (I was messing with the configurations and completely mess the operating system) and had to reinstall everything and now it’s working again.

Just to leave some notes on my quest:
1 - If you upgrade the RaspberryPi4 with the new firmware that allows booting for USB, you cannot use the SATA Hat because it doesn’t activate upon boot, so, your hard drive (if you wish to use a hard disk on the SATA Hat) cannot be used to boot.
2 - For some reason, this upgrade changes some stuff on the OS system (don’t know what because I am not an expert in Linux). Even if you return to your previous firmware, some of the files will continue to be changed and you cannot use the full potential of the SATA Hat

Without this, the FAN, the OLED display, and the HDD LEDs do not work, although the HDDs are still detectable by the system.

Please note that I noticed that, after changing the firmware, the module OLED gets an error, so, if you debug the main.py used to control the SATA Hat, you will check that when you import OLED, it cannot import, thus, on the main function (inside main.py) you cannot define the variables for the OLED.

import sys
import fan
import misc
import oled
top_board = 1
except Exception:
top_board = 0

Also, when trying to debug why OLED cannot be imported, I notice that there was an error on something called ADAFRUIT GPIO, so, I can only assume that, upon firmware upgrade, this ADAFRUIT library breaks, so, OLED cannot be imported and you are dropped to the misc.wait() function.

I noticed that removing the OLED import line, the fan and the HDD LEDs worked just fine.

I hope someone can figure out this but for me, it’s the end. In the end, I returned to the old firmware, flashed my SD card with the OS, and configured everything as normal.

Thank you for your information, which should be useful to fix the bug.

1 Like

I hope you can find solution fast, because like many RPI with SATA HAT i’m planning to boot on SSD to have better speed and avid to high usage of Microsdcard.