Raspberry Pi OS - Bookworm support - Any plans?

Hello, I tried to the best of my ability to get this running on Raspberry Pi Bookworm, 64-bit lite. However, I think the virtualization requirements around python is preventing the setup scripts from running. I have no idea how to change that. Will there be an upgrade for this? Or does someone have any advice on how to update it on our own?

I have flashed Raspberry Pi Legacy 64-bit lite, and it works. This is the Bullseye version, for now. I’m not sure when support will complete stop for that version.

@setq can you help to check this

Hi AhnFire,

We will support Bookworm in the next week or two.

1 Like

That is great! :slight_smile: I currently set up on Bullseye, but I am not too deep into it yet, in that case I will only set up a few simple things and get ready for the upgrade. Sound good!

By the way, some of the issues I found when I first tried Bookworm, was that there were python permissions errors also the Adafruit Library I think may have moved to Adafruit CircuityPython SDD1306 or something like that. Anyway, thank you for your efforts!