Radxa Zero 3W - MRAA "No Pins"


I have just received delivery of a couple Zero 3W’s which I believe have the most recent version of the Wi-Fi/BT chip (Wi-Fi 6).

I have downloaded and installed the latest available version of the OS for use on this board and Wi-Fi chip.

OS Version – radxa-zero3_debian_bullseye_xfce_b6.img
Build - Linux radxa-zero3 5.10.160-26-rk356x

Everything seems to work well with the exception of the GPIO pins.

From a fresh install and after doing the following as per the instructions MRAA installs but has no access to the GPIO pins.

sudo apt-get update
sudo apt-get install libmraa2 libmraa-dev libmraa-java python3-mraa mraa-tools
sudo mraa-gpio version returns “Version v2.2.0 on Unknown platform”
sudo mraa-gpio list returns “No Pins”

Doing the exact same procedure on a Radxa 4C+ works as expected (also on Bullseye and MRAA v2.2.0).

I have also tried OS version – radxa-zero3_debian_bullseye_xfce_b4.img but this gives the same results.

Is there an issue with the OS or is it MRAA as it doesn’t even recognise the platform?

I would greatly appreciate some advice to help me resolve this problem?

Kind regards


The Zero3 is “too new”, your version of mraa seems doesn’t supports it (“Unknown platform”). However, there seems to be support in nascs fork:

Hence, either wait until it is merged into radxa’s official version, or build libmraa yourself from this fork.

Thank you XT3, that has done the trick.

I compiled the fork you suggested on OS version ‘radxa-zero3_debian_bullseye_xfce_b6.img’ and I have access to the GPIO pins now. Tested GPIO, PWM and I2C.

Also thanks to nascs for updating the library.

Kind regards

please can i give me more detail about process and description of instruction for solved problem (MRAA “No Pins”) i work in the some os and card radxa zero 3w