Radxa Zero - 2GB RAm with 8GB EMMC - no WIFI

Hi, I tried flashing various distributions ( that would fit) onto the EMMC, mostly Ubuntu flavours, but I cannot seem to activate WiFi on any of them. All of the Ubuntu flavour distro’s seems to have the same instructions on the wiki:

$ sudo su
$ nmcli r wifi on
$ nmcli dev wifi
$ nmcli dev wifi connect “wifi_name” password “wifi_password”

Running these commands have zero output.

My issue is that I need to get the MAC address for the WiFi adapter first before I can connect to my AP, so the last line will not connect, but I tried looking in the system files to see if the wifi device is somewhere after turning it on, but I cannot see it.

Also, is there a way to write the image from the SD card to the eMMC, or is the only way to do that by using the python flash tools?

Update: found some more info on another thread.

After running:

$ sudo su
$ nmcli r wifi on
$ nmcli dev wifi

I then just try to do a:

nmcli device show

It only shows the loopback device.

I then disabled my wifi access point mac address checking, but when I try to run the actual wifi connect command the response is:

Error: No Wi-Fi device found.

Hi Piie, please post the dmesg.

Hi

Output of dmesg on terminal is basically a gazillion lines consisting of:

fe.dai-link-0: Asoc: no backend DAI’s enabled for fe.dai-link-0 - cannot see/ scroll up to what was before.

I’m trying to install the May 20 version of the release as well now - hoping it will help…

Really disappointed and extremely frustrated. Literally a chore to get even the simplest things to work.

Looked at various other threads that seem to have similar issue, none of the “solutions” work.

Tried removing and adding the device with rmmod and modprobe - nothing.

Then tried getting a bluetooth link between my phone, then my Windows PC and finally my Macbook - after more than an hour, the best I can now get is being able to send a file TO the radxa zero, and being bale to browse the zero, but %^&%^ knows where you are actually browsing, since it’s not the same place where I can send the file to - so suffice to say, I CANNOT GET THE ^&**(&&^&^ dmesg file from the device in order to post here. But seriously - even if I did, and looking at all the other threads about this I’m just getting the idea these are crap devices. EVERYTHING is a bloody mission - why can the boards not come with a proper Linux on the eMMC already?

Anyway - don’t even bother to respond - this crap wasted days of my time now - going back to the supplier, and if they don’t want to refund me they can go straight to the trash - not worth my time.

Hi, @Piie

Can you take a picture of your board? Also, which image have you tried? Please send a link.

Same exact problem here, with identical symptoms.

Don’t have the boards anymore, they were returned to supplier. Apparently lots of other customers who bought same boards have the same problem.

I’ve tried all the Ubuntu flavoured official Radxa images available from the wiki download page as well as the Manjaro image. Note about the Manjaro image - there seems to be a weird display issue on that distro that causes a green hue on the screen - made me think there was something wring with my HDMI cable, but other distros display correct.

As of late we are producing Radxa Zero with AW-CM256SM wireless module due to part shortage. This requires additional firmware and is now included in our latest image. We expect 3rd part distros to follow suit soon.

1 Like