Quad SATA-kit Top Hat install script missing


I received my order of 3 x “Quad SATA-kit”. Overall I’m happy with the quality of the kit, however when I try and install the " SATA HAT Top board" software via the command provided:
“curl -sL https://rock.sh/get-rockpi-sata-hat | sudo -E bash -”
It fails, due to the fact the that path returns a “404 Not Found” error. Can you fix this please?

Can you also clarify the power requirements when using the kit with 2 or 4 2.5" 1TB Hard Drives? Can I power it via the USB-C connector? And if so, what amperage do I need to supply?

Look at top part of sticker on your hard drive, there will be something like 5V XmA. Summ up all values and you will get how much you need in total.

I would say - around 3A for 2.5’’ x4

Hi mlsmith,

Sorry our short link service is down, please use the following command instead

curl -sL https://cos.setq.me/rockpi/sh/get-rockpi-sata.sh | sudo -E bash -

And this will install the drivers for the TOP HAT? I ask because I can already access the drives. They work just fine.
It’s the TOP HAT (Top Fan, OLED Display and push button) that’s not working.

I tried swapping the Top hat and wire harness from one of the other kit’s and it’s still not working.

Yes, it will install everything.

Then I have an issue.
As mentioned, I received 3 Kits. I have already tried to replace the top hat and 10 pin cable and it still did not work. Can the issue be coming from the SATA Hat?

How do I check to make sure the drivers for the top hat are installed? Is there an error log that the drivers write problems out to?

Whether all top-board can’t work?

Please check the permissions of the related folders. There was a case where this error message was thrown.

The directory ‘/home/pi/.cache/pip/http’ or its parent directory is not owned by the current user and the cache has been disabled. Please check the permissions and owner of that directory. If executing pip with sudo, you may want sudo’s -H flag.

The directory ‘/home/pi/.cache/pip’ or its parent directory is not owned by the current user and caching wheels has been disabled. check the permissions and owner of that directory. If executing pip with sudo, you may want sudo’s -H flag.

Once the permissions have been correctly set everything worked as expected.

1 Like


I had the exakt problem and I just figured it out.

Before I was starting the service as sudo or as root but for some reason that didnt work.
If I stopped and started the service as PI and then authenticated as root it worked…
I’ll post a picture of my commands for clarification

Can’t get it to work steadily. At reboot it wont show up again and if I try the same trick the display will not show anything. I tried rebooting again and it still didnt work. Then after a few attempts it started to show info on the display again.

Also reinstalled the service and then it started to work again until i restarted it.

Ok, I tried this method three times, no change. Thanks for the information though.

One issue might be, that the ‘/home/pi/.cache/pip/http’ directory does not exist. I’m posting what my ‘/home/pi/’ directory looks like:

I also just got in a new Power supply for the system. It’s rated to 65W, so I’m pretty sure that’s not the issue. I also powered it via a PC Power Supply to make sure.

I’ve tried all three Top Hats that I have as well as swapped out the Quad SATA board for another one. I’ve also tried one of the other 10pin cables that go from the SATA Hat to the Top Hat. Still nothing from the Top Hat. No Fan, No OLED, No Button.

When power is initially connected, the Fan moves for a fraction of a second, so power is getting to it.

I’ve also wiped Rasbian and reinstalled everything per the instructions. Same result.

What Logs can I attach to trouble shoot this more?

Please tell me the print of systemctl status rockpi-sata.service

Please tell me the print of i2cdetect -y 1

root@ZorensNAS:/home/pi# i2cdetect -y 1
Error: Could not open file /dev/i2c-1' or /dev/i2c/1’: No such file or directory
root@ZorensNAS:/home/pi# modprobe i2c-dev
root@ZorensNAS:/home/pi# modprobe i2c-bcm2708
root@ZorensNAS:/home/pi# i2cdetect -y 1
0 1 2 3 4 5 6 7 8 9 a b c d e f
00: – -- – -- – -- – -- – -- – -- –
10: – -- – -- – -- – -- – -- – -- – -- – --
20: – -- – -- – -- – -- – -- – -- – -- – --
30: – -- – -- – -- – -- – -- – -- 3c – -- –
40: – -- – -- – -- – -- – -- – -- – -- – --
50: – -- – -- – -- – -- – -- – -- – -- – --
60: – -- – -- – -- – -- – -- – -- – -- – --
70: – -- – -- – -- – --

If I reboot, I have to run the modprobe commands again otherwise, I get the same error message.

Please tell me the print of tail /boot/config.txt

root@ZorensNAS:/home/pi# tail /boot/config.txt


Enable DRM VC4 V3D driver on top of the dispmanx display stack



Everything seems normal, I need some time to find out why.

Thank you for your patience.

Ok, thanks for responding so quickly.

I made a little change to the software. Please reinstall it and reboot, and then tell me the result.