Quad SATA Hat with Rock Pi 4 C+ how to install?

Hi there,

has anyone tried the setup of Quad SATA Hat with the Rock Pi 4 C+ ? I tried it but can’t get it running. I tried with Debian Buster and Bullseye, as well as Ubuntu Focal. Whenever I run the script provided by the installation guide

curl -sL https://rock.sh/get-rockpi-sata | sudo -E bash -

it installs all the python packages, and eventually installs the service and config of Penta Hat in

/lib/systemd/system/rockpi-penta.service

which is obviously the wrong package chosen by the script.

It is not a hardware but a software issue, because I tried the Quad SATA Hat with fan and display on a Raspi 3b+ and there it worked and the script installed rockpi-sata.service

I coulnd’t find any instructions on how to get the Hat working with a Rock Pi 4 C+ board, so I would be glad if someone could help. Thanks

The Rockpi 4 C+ uses the Penta Sata Hat, which connects through its PCIE connection. This provides it a high-speed access that provides access to the individual drives upon boot, without additional software, since it is a direct hardware connection.

The Quad Sata Hat is connected to a Raspberry Pi through twin USB connectors, with the supplied bridge.

Both Hats have similar user interface characteristics but the underlying software is very significantly different at the hardware interface level, and each uses different libraries and APIs for access to the hardware.

As such the installers do not examine the underlying HAT hardware but base their decisions on the hardware of the SBC. So on a Rockpi you get Penta Hat software, on a Raspberry Pi you get Quad SATA hat software. There is no installation package that allows a Quad Sata Hat to be used on a Rockpi, though one could modify the Quad Sata Hat code to work on the Rockpi, but you would have to do the conversion and installer yourself. You would not be able to use the Penta Hat on a Raspberry Pi since there is no hardware PCIE interface.

Note that though the Penta HAT hardware on a Rockpi is immediately functional, without the install software, the Quad SATA Hat, with its USB to SATA drivers must be enabled through a GPIO before the HAT is actually visible to the device drivers, requiring the radxa installer to have run and setup the libraries and installed the code.

This is interesting. Thanks for the reply! Knowing all this, I wonder why allnet.china offers the Quad SATA Hat in a bundle with the RP4C+ , which seems misleading, because they advertise it by stating that RP4C+ can be used as “replacement” for the RaspberryPi4 . Unless one is able to code own scripts, it seems not possible to get them running together for now. If anyone here happens co come across the same situation and has already done the job of modifying the installer, it would be awesome if they could help by sharing it. Possibly other people who also bought the bundle RP4C+/QuadSATA would be grateful for this, too.

One question though, are you sure the RP4C+ would work with the PentaSATAhat? I just checked the product sheet and found this description for the M.2 Connector:
“The ROCK Pi 4C Plus offers a M.2 M Key socket with PCIe 2.0 x4 interfaces, providing high speed bus
access, a standard M.2 2230 mouting hole is on board for 2230 form facor NVMe SSD. SATA SSD is not
supported.”

The M.2 Connector of RP4B+ is described as “The ROCK Pi 4 Plus offers a M.2 M Key SSD socket with PCIe 2.0 x4 interfaces, providing high speed SSD access”

A caveat: my experience has been through the Penta Sata Hat kit: https://shop.allnetchina.cn/collections/sata-hat/products/penta-sata-kit-for-rock-pi-4-model-a-b-a-b-and-rock3a-with-order-reward and the Quad Sata Hat kit: https://shop.allnetchina.cn/products/quad-sata-hat-case-for-raspberry-pi-4, and both systems are at least a year old.

So I cannot specifically address an allnet china Quad Sata Hat with an RP4C+. My personal experience with the hardware (Penta hat with the Rockpi and Quad Hat with the Raspberry pi) has been good, and I have done a fair amount with the source for both HATs (of the vintage I have), but no attempt to use a system of the configuration you are indicating.

I was unable to find a link to an allnet china Quad Sata Hat for Rock pi 4C+. Could you supply one? Was your hat was purchased alone, rather than as a kit, and then assembled with a Rockpi 4C+?

The second link you wrote has a bundle option, called black edition with rock pi 4c+. this is what I ordered and received. if you scroll to the bottom of the page, you can find the hint that the rpi4c+ can be used as a replacement for the raspberry pi. so yea, I wonder what’s the idea to sell them together like this, if there’s no software released to operate them successfully. physically it fits together, the boards as well as the chassis.

Most interesting. Hardware without software is of limited use.

Unfortunately I do not have such a system and can only sympathize, rather than being useful.

Hi [Walter_White],

I have ordered the same Kit as you and I have a Rock Pi4plus It is going to arrive

I actually don’t have a PCIe/M2 slot so I am expecting this to work.

Can I ask what Rock Pi4c+ you have as mine does not have a

Mine is the one below so I am expecting it to work. (fingers crossed)

Hi, sorry I don’t quite understand, which model of the Rock Pi do you have? There’s only one type of the Rock (Pi) 4C+ and that one didn’t work in this setup due to lack of software support. If you read okets replies above it is mentioned that the installation for the Quad SATA head was not scripted for the Rock 4C+ architecture but it would always install the driver package for the Penta SATA kit. I have meanwhile gotten my hands on a Raspberry 4 and with that, the Quad kit works immediately. So either you have to wait for the installation script to be updated by Radxa (if not already done) or rewrite it yourself or use a Raspberry Pi.

Please share your experience if there is any useful information.

Cheers

Hi Walter_White,

Sorry, it wasn’t clear.

They state on the offical page (quad-sata-hat-case-for-raspberry-pi-4) the following

->>Rock Pi 4 Model C+ can be used as replacement<<-

BUT PLEASE NOTE:

The M.2 (M) 2230 up to 2T M.2 NVME SSD via PCIe 2.0 x4 interface must not be populated in this setup!

Just add your Raspberry Pi 4 (Rock Pi 4C+) to this Kit and your NAS is complete and it really looks great!

However my Rock Pi 4C+ does not have a M.2 Slot. So I am wondering will this even work with my Rock Pi 4C+ as I now see that I the Okdo Rock Pi 4C+ and not the Radxa Rock Pi 4C+. It still seems to use the same chip so perhaps it maybe compatible.

As you say, I may have to switch to a Raspberry Pi 4.

Oh that’s interesting. So there are different revisions of the Rock 4 C+ model, I wasn’t aware. It would be interesting to know if your model works with the kit, however I don’t believe it would, as the architecture is the same and missing an M.2 slot wouldn’t make a difference for the script to make a choice of the installation packages. At least that’s my assumption, but it would be great if you can share your experience after testing.

I am actually in the process of returning the Okdo Pi 4c+ to conrad.nl as even their site didn’t state the correct info.

The Quad KIT still has not arrived from allnetchina, but if he does in the next few days I may keep it to try it, but as you say…i’m not expecting it to work.

I just had a chat with the support team and they are pushing a new image now to https://github.com/radxa/debos-radxa/releases

They have a test bench machine that uses the Rock Pi 4c+ using Debian Buster https://github.com/radxa/debos-radxa/releases. The release is still updating but I suspect it will be there by the time you read this.

I am going to retry with my Okdo Rock Pi 4c+ with this new image.

Awesome. That is good news for people who intend to use the quadkit & rock4c+ setup. As for me, I meanwhile got myself the penta hat kit with a rock4a board, as it uses pcie lanes via nvme connection and comes with e-sata connection. I’m quite happy with the transfer rates of about 110MB/s I got when using it as file server in my LAN. Anyways, I’m sure it would be appreciated if you happen to be able to test the hardware with the new debian build and keep us posted!

Cheers!

Walter_White,

You know, i’ve tried every possible os with every possible version and it will not work no matter what I try, heck I even tried changing the scripts manually line by line to see if I could get it running, but no, nadda, nothing, zip! So I gave up and tried a old Raspberry Pi 2 that was laying in a box…and whaaadya know, first time it installs & works…can see all the drives and LEDs working :exploding_head:

What really bugs me is how allnetchina guys can state this :

Just add your Raspberry Pi 4 (Rock Pi 4C+)

So for now I will do some further testing until I can get my hands on a Pi 4 4GB for less than 100 euros.

Oh & I am also keen to see if this works…

PENTA SATA KIT for ROCK PI 4 Model A/B, A/B+ and Rock3A (with order bo – ALLNET China

oh, that’s surprising, as you said you have been talking to the service staff. thought they’re aware of the situation. frankly, I was seriously disappointed by the whole thing, because the product is advertised as compatible when it’s not. I had exactly the same line of thought as you, and I had tried tried every available image and tried to alter the installation command or copy the Quad service file to the system but nothing worked. Service staff of allnetchina stopped responding to my messages after I asked them for support on this problem. I just don’t get it why they won’t even change the offer to be transparent about the product’s incompatibility. it’s unprofessional and misleading. well, I’m sure you’ll get it running eventually if you use the setup with a Raspberry Pi.

1 Like