Quad SATA Hat doesn't recognise two disks


I just bought the Quad Sata Kit from allnetchina and I have installed 4 x Seagate Barracuda 2.5 inch 2TB drives.

All 4 disks lights are on but the system sees only two of them sda and sdb. I checked all the disks in my computer and they are working fine. So this is not a disk problem. Then I try to install them one at a time in the Quad SATA Kit’s slots. It seems that the SATA 3 and SATA 4 connections are not working (see attached image below).

The SATA 1 and the SATA 2 connections are working fine. Do I need a replacement or is there any other solution?

Kind regards,

Well I think I found what the problem is. The USB connector that the kit comes with is bent and can’t go all the way through. See the images below. Can you tell me how can I get a replacement? Shall I get in touch with ALLNET China?


Hi, @sboutas

I am sorry for this issue. You can just contact Allnet and they will send you another 4x USB adapter.

Hi all,

Just to give you an update on this one.

I have tried all the things Allnet China proposed and still I can see only two hard drives.

It’s clearly a hardware issue either on Quad SATA hat, USB connector or both.

I have requested for a replacement. I will let you know how this goes.

This is actually mentioned on the troubleshooting steps, is this from the Cli or open media vault?

It’s from the Cli.

Ok I sent the faulty parts (Sata hat and USB connector) back to Allnet CHINA and they told me they sent ne the new ones on Monday.

They gave me a tracking number and a service to track the parcel https://www.17track.net/en

They told me that I should receive it in 3-4 weeks which for me is unacceptable since the first time when I ordered the kit the delivery was fast (took 5 days). The package I sent them it will arrive in less than a week.

I am very dissaponted because I have to wait all this time for something that was not my fault in the first place.

Anyway, I am using the service they provided me with to track the parcel and I can’t see anything yet. They told me it will appear later when it is updated. It has been 4 days now.

I will let you know once I receive the new components and how everything goes.

I got the new Quad sata hat from all Allnet China and it seems to work.

I can see all 4 disks in linux now. I have also updated the firmware of JMicron controller followed the instructions of another post in here.

Now the problem is that OMV shows up only 4 disks. I have tried all the fixes proposed and nothing works for me.

Also, I have Seagate drives and the system reports them as WD. Maybe the controller is messing the info up.

Any ideas?

After following the instructions here https://wiki.radxa.com/Dual_Quad_SATA_HAT to the letter, all 4 disks appeared in OMV.

Thank you Radxa and the community for putting all these together.