Quad SATA HAT Assembly and Troubleshooting


Try to execute the following command, then use fdisk and mkfs.ext4 in Raspberry Pi.

sudo wipefs /dev/sda1 -a -f
sudo wipefs /dev/sda -a -f

Be careful: these operations will cause data loss on your hard drive.

every time I run "
curl -sL https://rock.sh/get-rockpi-sata | sudo -E bash -"
whether I’ve installed raspberrypios, dietpi, or ubuntu on my raspberrypi 4 4gb I lose the ability to ssh into the raspberry pi.
It work fine before running above command but afterwards it doesn’t.???

The installation script does nothing to affect ssh. Did you do anything else?

No all I do is a fresh install apt update apt upgrade, set up ssh. Use shh. Run the script. Restart and ssh with via WiFi or Ethernet stops working. Exactly the same on as above Ubuntu, raspberryos, and DietPi.

I have been using (on separate pi) DHCP via pihole, and am checking now if using router instead works.


May be due to the execution of an apt upgrade? Try not to run the script and reboot after the upgrade completes.

That my have done the trick. It seems to be working now thanks.

Not sure whether it was pihole DHCP turned off or your suggestion.

I was away for the weekend, but finally got some time to play around with the pi again yesterday. Here is what I got:
The wipefs command removes some bits (at least on /dev/sda1), but takes a long time using the sata hat. Like 30 minutes for one of the commands by a rough estimate (I did not measure). After that I did an sudo fdisk -l, to see what was being registered. This did not always complete. It would show all the ram and the SD card and the old HDD (as /dev/sdb), but not manage to show /dev/sda and just sit there, wasting my time. I established a second ssh connection the pi to get some dmesg, just in case.
You can download the dmesg here: https://filehorst.de/d/dudeoHti

To reiterate: The SSD works well with my ubuntu laptop and directly with the pi using a cheap USB to Sata cable. I can also wipe the file system, remove the old partition, add a new one and format as ext4 using the USB to Sata cable to connect the SSD to the Pi and everything is buttery smooth. The problems only occur when I connect the SSD using the radxa Sata hat. I’m pretty sure by now that the drive is not to blame.

I read somewhere that software hanging issues can occur when the power is weak. I am using the 12V 5A power supply allnetchina send over as a promotion for the kit. That should be plenty strong. However, I am also using the Pi4 8GB version which changed some power supply details. Does your power delivery design work with those changes?

What would you have me do to fix the sata hat board? I would really like to get it to work properly, otherwise I have just wasted a bunch of money.


Disabling UAS may help. Can you try it?

Refer to: https://www.raspberrypi.org/forums/viewtopic.php?t=245931

Hi setq,
disabling USA seems to have helped. Now I can wipe the filesystem and delete the partition, create a new partition and make the filesystem. I do notice a slight lag when typing in ssh terminal, though. That wasn’t the case before.

I also installed openmediavault to make my life a little easier and I implemented the fix for OMV only showing two drives (Quad Sata Kit and OpenMediaVault 5 (Raspberry Pi 4)).
Unfortunately, the SSD is not picked up by OMV. I suspect it has to do with the fact that I can see the drive using lsblk, but not using blkid in a shh terminal. Can you help?

/dev/sda is the ssd, /dev/sdb is a regular hard drive, here.

Edit: Nevermind, for some reason OMV allowed me to mount the ssd and set up a samba share. However the write speeds I am getting are pretty low. In the 1-5 MB/s range…

@besetzt What file system is sda1?

Did install and used commands
sudo apt-get install i2c-tools
sudo i2cdetect -y 1

and still cant see hat doesn’t show 3c it shows nothing

@evlsmurf Can you see 51?

@setq No i dont


Does it output nothing or does it report an error? Did you reboot after installing the script?

nothing outputs rebooted and tried everything above

Can you see the hard disk and USB through lsblk and lsusb -t?

i have 2 ssd’s installed


Is your hat version 1.2? Does the fan work?

fan does not work and how do i tell version? i think 1.2 it has barrel plug on it

cant even upgrade hat fw with sudo ./JMS561FwUpdate -b backup.bin -f jms561b_v8.1.3.6.bin -d /dev/sdc
tried hd’s in all locations


I noticed that after loading something on NAS its activity LEDs flashing constantly. Is that how it should be? Does it mean that hard drivers don’t stop spinning?