QUAD SATA Fan not working

My FAN start no running after update I think…

I read a lot of previous post, try to update the pigpiod.service like below but fan still not run:
pi@raspberrypi:~ $ sudo cat /lib/systemd/system/pigpiod.service
[Unit]
Description=Daemon required to control GPIO pins via pigpio
[Service]
#ExecStart=/usr/bin/pigpiod -l
ExecStart=/usr/bin/pigpiod -n 127.0.0.1
ExecStop=/bin/systemctl kill pigpiod
Type=forking
[Install]
WantedBy=multi-user.target

pi@raspberrypi:~ $ systemctl status pigpiod.service
● pigpiod.service - Daemon required to control GPIO pins via pigpio
Loaded: loaded (/lib/systemd/system/pigpiod.service; enabled; vendor preset: enabled)
Active: active (running) since Thu 2022-03-03 20:59:10 HKT; 23min ago
Main PID: 451 (pigpiod)
Tasks: 6 (limit: 4915)
CGroup: /system.slice/pigpiod.service
└─451 /usr/bin/pigpiod -n 127.0.0.1

3月 03 20:59:10 raspberrypi systemd[1]: Starting Daemon required to control GPIO pins via pigpio…
3月 03 20:59:10 raspberrypi systemd[1]: Started Daemon required to control GPIO pins via pigpio.

pi@raspberrypi:~ $ pigs t
1431047711

pi@raspberrypi:~ $ ping localhost
PING localhost(localhost (::1)) 56 data bytes
64 bytes from localhost (::1): icmp_seq=1 ttl=64 time=0.121 ms
64 bytes from localhost (::1): icmp_seq=2 ttl=64 time=0.118 ms
64 bytes from localhost (::1): icmp_seq=3 ttl=64 time=0.134 ms
64 bytes from localhost (::1): icmp_seq=4 ttl=64 time=0.120 ms
64 bytes from localhost (::1): icmp_seq=5 ttl=64 time=0.067 ms
64 bytes from localhost (::1): icmp_seq=6 ttl=64 time=0.121 ms
64 bytes from localhost (::1): icmp_seq=7 ttl=64 time=0.112 ms
64 bytes from localhost (::1): icmp_seq=8 ttl=64 time=0.111 ms
64 bytes from localhost (::1): icmp_seq=9 ttl=64 time=0.111 ms
^C
— localhost ping statistics —
9 packets transmitted, 9 received, 0% packet loss, time 340ms
rtt min/avg/max/mdev = 0.067/0.112/0.134/0.021 ms

pi@raspberrypi:~ $ sudo systemctl status rockpi-sata.service
● rockpi-sata.service - Rockpi SATA Hat
Loaded: loaded (/lib/systemd/system/rockpi-sata.service; enabled; vendor preset: enabled)
Active: active (running) since Thu 2022-03-03 21:12:20 HKT; 17min ago
Main PID: 5674 (python3)
Tasks: 3 (limit: 4915)
CGroup: /system.slice/rockpi-sata.service
├─5674 /usr/bin/python3 /usr/bin/rockpi-sata/main.py on
└─5884 /usr/bin/python3 /usr/bin/rockpi-sata/main.py on

3月 03 21:12:20 raspberrypi systemd[1]: Started Rockpi SATA Hat.

pi@raspberrypi:~ $ netstat -a | grep 8888
tcp 0 0 0.0.0.0:8888 0.0.0.0:* LISTEN
tcp 0 0 localhost:8888 localhost:51942 ESTABLISHED
tcp 0 0 localhost:51942 localhost:8888 ESTABLISHED
tcp 0 0 localhost:51940 localhost:8888 ESTABLISHED
tcp 0 0 localhost:8888 localhost:51940 ESTABLISHED

Please help, I know this like a monthly question…

I believe that I have read in the forums that the problem occurs when you have IPV6 enabled.

fan.py has the following line:

        host = misc.check_output("netstat -l | grep -o '\S*:8888' | tr -d ':8888'")

Try commenting this out and simply set host to ‘127.0.0.1’ and see if this bypasses the IPV6 possibility.
Your pigpiod service config had the entry:

ExecStart=/usr/bin/pigpiod -n 127.0.0.1

suggesting it will be listening on IPV4.

See: https://raspberrypi.stackexchange.com/questions/104439/why-are-some-services-only-listening-on-ip6

Thanks, where is the path for fan.py?
Just to be clear. I should edit the lines in the fan.py as below:

# host = misc.check_output("netstat -l | grep -o '\S*:8888' | tr -d ':8888'")
host =127.0.0.1

The file is /usr/bin/rockpi-sata/fan.py

That would be my suggestion to see if it works. If you look in your /etc/hosts file you would see the possibility of two ‘localhost’ definitions like:

127.0.0.1 localhost
::1 localhost ip6-localhost ip6-loopback

My pigpio daemon (sudo systemctl status pigpiod.service) shows the daemon started as '/usr/bin/pigpiod -l) and I am not having your problem, so I have not changed the line in my running code, but had tested it before and gotten a good connection.

After modified the fan.py, all my Harddrives are gone after reboot, cannot see in lsusb and lsblk.

but after change it back, then all the drivers appear again.

Did you get the service to start, or was there an error? Check ‘systemctl status rockpi-sata.service’ to see if there are log entries or errors from python.

pi@raspberrypi:~ $ systemctl status rockpi-sata.service
● rockpi-sata.service - Rockpi SATA Hat
Loaded: loaded (/lib/systemd/system/rockpi-sata.service; enabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Fri 2022-03-04 12:17:29 HKT; 1min 12s ago
Process: 922 ExecStart=/usr/bin/python3 /usr/bin/rockpi-sata/main.py on (code=exited, status=1/FAILURE)
Main PID: 922 (code=exited, status=1/FAILURE)

3月 04 12:17:29 raspberrypi systemd[1]: rockpi-sata.service: Service RestartSec=100ms expired, scheduling restart.
3月 04 12:17:29 raspberrypi systemd[1]: rockpi-sata.service: Scheduled restart job, restart counter is at 5.
3月 04 12:17:29 raspberrypi systemd[1]: Stopped Rockpi SATA Hat.
3月 04 12:17:29 raspberrypi systemd[1]: rockpi-sata.service: Start request repeated too quickly.
3月 04 12:17:29 raspberrypi systemd[1]: rockpi-sata.service: Failed with result ‘exit-code’.
3月 04 12:17:29 raspberrypi systemd[1]: Failed to start Rockpi SATA Hat.

Do you get any output/error if you run manually the service?
/usr/bin/python3 /usr/bin/rockpi-sata/main.py on