Penta SATA Hat Fan Always at 100%

Reposting this here in the hopes that it will get more attention…

I have been running armbian-based openmediavault on my Rock 4A pretty much since I received it. I have the Penta SATA Hat and the SATA Hat Top Board installed in the 4-bay metal case.

The first version I installed was OMV 5. The whole time it was running, I couldn’t get the OLED display to work, though the fan worked great. I assumed the display was bad and Radxa sent me a new top board, but I never got around to swapping it.

After OMV 6 became available, I upgraded to that. The fan was running full tilt and the display wasn’t working, so I reran the script for the top board. Lo and behold, the display started working! Also, after the install, the fan worked as before.

Recently I upgraded to OMV 7 and again the fan went back to running at full speed, but this time the display continued to work. Regardless, I tried rerunning the script, and this time it did nothing for the fan. I also installed the deb package that I found on the Radxa site, still to no avail.

Could anyone advise how to fix this issue, or at least debug it? At this point, I have to keep shutting down the NAS when I’m in the same room, whereas before, it was virtually silent.

I don’t mind doing some work in order to get this working again, but I don’t know where to start. I’m a decent programmer and I’ve been using Linux for a long, long time, but have little experience working with the GPIO pins on SBCs.

Anything that would help me get pointed in the right direction would be much appreciated.




Don’t know if it is of interest or still works with the latest rock 4 PENTA, but it has been running for me without pause for the last few years

The problem with my display is that I don’t have a working version of the Adafruit GPIO library. It’s been deprecated in favor of their Blinka library, which (unsurprisingly) is two years old now.

Normally you would get the library in with: pip3 install adafruit-circuitpython-ssd1306

Or is it happening to you the same as: Rockpi 4 not work Adafruit oled

I just tried that command and it indicated that everything it was supposed to install was already there.

In fact, I have a directory in my home directory called “Adafruit_Python_GPIO” that has a “” file and an “” file. I can’t get either of them to work though.

This article on Stack Overflow has a suggestion.