SATA Hat Top Board Issue

I have been running armbian-based openmediavault on my Rock 4A pretty much since I received it. I have the Penta SATA Hat and the SATA Hat Top Board installed in the 4-bay metal case.

The first version I installed was OMV 5. The whole time it was running, I couldn’t get the OLED display to work, though the fan worked great. I assumed the display was bad and Radxa sent me a new top board, but I never got around to swapping it.

After OMV 6 became available, I upgraded to that. The fan was running full tilt and the display wasn’t working, so I reran the script for the top board. Lo and behold, the display started working! Also, after the install, the fan worked as before.

This past weekend, I upgraded to OMV 7 and again the fan went back to running at full speed, but this time the display continued to work. Regardless, I tried rerunning the script, and this time it did nothing for the fan. I also installed the deb package that I found on the Radxa site, still to no avail.

Could anyone advise how to fix this issue, or at least debug it? At this point, I have to keep shutting down the NAS when I’m in the same room, whereas before, it was vitually silent.



To run all components You need supported python with needed libraries as well as overlay to turn on i2c line.
Check out penta-sata-hat service for logs, it may already contain information about thrown error.

Also please not that not every os and software is supported by this product. Newer systems comes with new set of libs and different python. Armbian builds many new kernels, but there is high chance that something big is not working. I recently tested something on 4b+ and new release downgrades pcie speed so it was not right choice at all. There is more of such issues and this is Your risk of using such automated build. Just reconsider using right image.

There are no logs, unfortunately.

The system is otherwise working just fine, as far as I can tell. It’s just this one thing that isn’t.

I didn’t realize that there was a SATA Hat category too, so I’ll try posting again there and see if I get more traction.


then just try to run commands from this service manually, You will probably get some output, maybe about missing python libs etc. Also You can run script outside service and see output.

Running on its own tells me that it cannot import the mraa module.

Running “add-apt-repository ppa:mraa/mraa” generates an error too. I added the repository for Ubuntu Focal (20.04), which is the newest version they support, but I had to add the public key in order to be able to do anything with it.

Now it tells me that I have libjson-c4 and libpython3.8 as dependencies, but neither is installable. I tried to force the install, but it just won’t budge.

I haven’t given up yet though…

As You can see this happens with newer systems,
You are on right way, either You can try to solve those dependencies or just move back to previous version where there are already all of them ready to be used. I tested that upgrade once but there were other problems (as far as I remember with kernel) and it was not running stable. This may be already fixed of course.

I have seen none of the stability issues that you’ve seen. My 4A is running as solid as ever.

I was able to install mraa and get my fan working again properly following the steps here: How can I use mraa? - ROCK 4 Series - Radxa Community

My display stopped working again, but I can live without that.

I agree with others who have commented that the software and documentation for these devices are woefully behind the times. To have distributions that are four years old and older as the newest “official” ones available is somewhat absurd.


Oh, and as far as PCIe performance is concerned, my NAS is able to fully saturate my 1Gbps network, which is all that I can ask for.

Probably some of devices are not fully compatible with this chip (and firmware version), others works just fine. I could not get it to work reliably with software RAID, it disconnects/rebuilds all the time, but same drives with hardware RAID mode work great.

Check out i2c lines and if it’s detecting device. Then errors and logs.
This OLED display looks awful after some time, this part should be easily replaceable (with option for larger, and maybe different -tft type).

This is not that hard with hard disks available today and there is no point for using ssds capable of 550MB/s when we have this limit on network. Stability is much more difficult concern here, not everything works reliable here. For pcie link - just check link speed do You have, downgraded link is still faster than 1Gbit ethernet.

If You have any notes about all changes feel free to publish those here, so more people will be able to jump to omv7.