No video output

I just got my new Rock Pi 4 out of the box. I put it together (I bought the kit with the Acrylic enclosure). I loaded Ubuntu Server from the Rock Pi website onto mSD card. Boot… No video. I’ve tried two different monitors and two different HDMI cables. It’s a blank screen. I see the Pi light up and the network port flashes during boot. Any thoughts? Am I doing something wrong? Or, could I have a defective HDMI port? Thanks.

Since I never got a reply here, I wanted to pass on the solution from the company. I ordered the Rock Pi in early January. It took several weeks to arrive. I’ve submitted for help with a lot of lag in the response. Ultimately, the Rock Pi is defective and has to be shipped back. The company expects me to send it back to Hong Kong. That shipping costs more than the device itself. They won’t replace it until they get the defective product. Then, I have to wait a few more weeks to get it.

BUYER BEWARE… If you have a problem, you’re out the money and time. I should’ve resisted the urge for more power and just bought the Raspberry Pi. Now, I have a piece of electronic junk that does nothing.

Hi, Kevan

The Ubuntu Server should only have the command line interface, what’s the resolution of your HDMI monitor? Have you tried other images? All the units we ship pass the QA in the factory. It’s highly not possible for defective unit out of box.

Hi Jack, and the rest of the @radxa team.
I today received the big heatsink for it. So I thought to try all the images again, and I built a few Armbian images.

With Ubuntu Server I had the same problem as @KevanC. No hdmi output. I left it on for 10minutes.
Then restarted the board a few times, and 1 time it did boot right. I could log in, but it was very unstable.
It hung on connecting wifi, I opened a new terminal and tried to reboot. But I also hung there. This was both with sd-card and eMMC.

The Armbian Bionic dev I built today worked. But it also needs more work to get it at an acceptable point. Wifi doesn’t work yet, and there seems to be a shutdown problem to.
Maybe someone of your team could help to solve these things so Armbian can get their RK3399 kernel to work great on the RockPi4B.
Then there will be no need anymore in supporting the Radxa Armbian Stretch.

I’ve red a few comments of unsatisfied people. Now I understand what their problem is. There are images available, but none are great.

The Armbian Stretch of Radxa seems the best sollution for now for me. I need to render some high res blender images. For that I need arm64 and enough ram. And that’s also a problem with this image. I can not install zram-config.

So also for me there is a problem with every image.

I know it’s a lot of work, and I understand this fully. Now you’ve got a bunch of OS’es, but the small problems are also multiplied. So that’s a lot of work.

In a month or so I’ll be making another video about the Desktop experience with my RK3399 boards. For now I’ll have to say the NanoPi M4 is better for this than the RockPi4B.
On Armbian Bionic there’s a media script for vpu support with Chromium and 4k video in Linux.
Also the official FriendlyElec images have this baked in.
If the official Armbian would be able to run well on the RockPi4B, then this will also work.

Otherwise I still love the board. It’s well designed. The big heatsink could use a redesign. It’s not workable to have to remove the heatsink to be able to reach the eMMC. I would buy a new heatsink if you would do that.

Thank you for all the effort, have a nice day. Keep up the good work.
Greetings, NicoD

1 Like

I have a similar issue with 2 out of 6 Rock pi4 (all ver1.4, all booting from emmc)
all using same dietpi image, 4 works great, but one is unstable and crashes after 2-3min after login other pi has no video out like OP mentions, but led shows normal activity. All with the big alu cooler and I rechecked for proper contact and thermal paste leak etc.

Tried booting from a mSD card, diff image and reburned the emmc but both rock pi4 have the same issue no matter what I do.

That’s potentially a hardware error on 1 out of 3 boards I bought. Not a great statistic.

I will try and order 2 more boards as I really need them to complete the cluster I am building and cant wait to ship the boards and wait for return. :confused:
It’s a real shame as I really love the rock pi4 when they work.
I hope I have just been really unfortunate.

Do you have the serial console to catch the crash log? If 2 of 6 crash, that’s really a big issue.

Hi Jack, unfortunately I dont have the serial console log.
I cant say for the one without video out, but the one that I can see crash, does give error messages before it crashes. Let me see if I can capture those, maybe someone have an idea of what is wrong.
Will post it once I can capture it.

1 Like


Sorry they might not be much help, but considering a pagefault-like errors I would have guessed corrupted memory maybe?

You are using some development image/kernel which is not supported or related to Radxa.

Perhaps that is the first main problem?

Use images with label “current” and kernel 5.4.8 / rebuild yesterday.

its worth noting that this version works just fine on the other 4 boards of same build.
I did try another image (manjaro I think it was that worked well on another board)

But let me try the official debian desktop image recommended from the radxa home page. :slight_smile:

Tells little.

Is made from totally different kernel.

1 Like

well, if the other v1.4 boards boards I have run the same kernel 5.4.0-rc1-rockchip64 stable, it stands to reason that this board should too, no?

Debian desktop 9 (rockpi4-debian-stretch-desktop-arm64-20190730_2022-gpt) does not boot at all, just a green led for power, no activity light. Same kernel or not, surely I should be able to boot the officially suggested image from radxa :wink:

Perhaps a HW quality/tolerance issues which was not yet fixed? Does .0-rc1 tells you something or nothing at all? I also know that mainline kernel for 3399 is months from the mature state.

Kernel is talking to the hardware.

Perhaps not. Why you are unable to boot it now? How about attaching a serial console. It could give some clues.

1 Like

Yeah, maybe you are right. I realize it is a release candidate and therefor not considered stable, but that is the version the dietpi distro comes with and before I have a change to downgrade it crashes.
Thats why I tried booting the debian distro from SD card.

Not sure as I dont get any video out using the debian distro.

Unfortunately I dont have the cable to do so, like I mentioned above in the thread.

Thank you for your replies. I will figure something out, but I am out if time for now.
Will post back here if I figure it out.
:slight_smile:

Hi @LucidScrubJay

I would recommend you to get a serial USB TTL device, these are quite essential to capture what is going on.
Here are some usb ttl devices which are compatible:

I would agree with you. In this case there are some networking issues with Linux 5.4.6+ so some devices may be more susceptible?

Both suggestions are from personal experience.
Kind regards.
:slight_smile:

Already fixed in most recent Armbian builds.

thanks, yeah I have been considering getting one even before this issue. :slight_smile:

Just wanted to give a quick feedback.
Only have had time to check a few other scenarios, but for what it is worth…

Armbian boots from emmc and SD, but dietpi image only boots from SD on this board. (Works on other boards)
So there is something odd with the dietpi and booting from the emmc on those two particular boards. Like mentioned earlier it might be a hardware tolerance thing for those emmc and rc version of the kernel in particular.

Will leave for now and try again once a non-rc version comes along.

Cheers all

The basis is a script that replaces few matured well maintained utilities with their amateur version checked by no one. “Upgrade” breaks system security as a side effects … which is then sold as an improvement to naive people :slight_smile: Kernel, the key component, comes from random location (stock, armbian, 3rd party).

Perhaps do some investigation.

Will do some if time allows for it. So far the 2 boards will just have to be added once I get around to it later if possible, Im no longer in a hurry.

I realize you feel strongly for Armbian, and it certainly seems like a strong and fast booting option, but keep in mind Armbian also did not boot on one of the boards using the emmc, but from the other okay.
And I realize you cant really help me without the tech readout that I would get from the serial connection and thats okay.
I just wanted to report back as to where I was at, because I said that I would. :slight_smile: