New Custom Debian ARM64 Build 4.4.154.c83 is finally here!


#21

I am trying to boot this image headless and with RX on pin 10 & TX on pin 8 I only get serial output up to and including Starting kernel ... then no more. All input ([ENTER], ^C, ^D, etc) seems to be ignored. Does “ttyS2” mean that the serial console is available on 2 different pins? TIA

example tail of boot output:

Retrieving file: /Image
reading /Image
19490824 bytes read in 816 ms (22.8 MiB/s)
append: earlyprintk console=ttyFIQ0,1500000n8 rw root=PARTUUID=b921b045-1d rootfstype=ext4 init=/sbin/init rootwait
Retrieving file: /rockpi-4b-linux.dtb
reading /rockpi-4b-linux.dtb
96696 bytes read in 7 ms (13.2 MiB/s)
fdt addr 0000000001f00000
fdt magic number edfe0dd0
fdt size 1048576
## Flattened Device Tree blob at 01f00000
   Booting using the fdt blob at 0x1f00000
   Loading Device Tree to 00000000f3cec000, end 00000000f3deefff ... OK
Adding bank: start=0x00200000, size=0xf7e00000

Starting kernel ...

#22

You may want to change console=ttyFIQ0 to console=ttyS2 in /boot/extlinux/extlinux.conf to use pin 8/10 as console.


#23

Worked like a charm – thanks.


#24

FYI … Intellisense appears to be working on mine. I had to manually install it as an extension.


#25

I’m assuming you are not using the Microsoft C++ extension? I downloaded other’s extension based on GNU Global and “kinda” working now, it knows keywords but still can’t “jump” to definitions, maybe I’m asking for too much in a new environment?


#26

I’ll play with it more today. Yesterday was installing ClamAv.


#27

Regardless it’s already decades better (literally) than vim.


#28

This is VsCode running on the RockPi debugging a React app through a VNC Viewer session attached wirelessly. Now I can place the little server anywhere in the house and develop ARM64 code. Look Ma! No wires.


#29

Which VNC server did you install on the Rock Pi? I tried TightVNC and the server wouldn’t start due to missing x11 fonts.


#30

I installed TigerVNC and xfce4 for it’s desktop services. It took a lot of configuration, but I’m running the client 3000x2000 24 bit so that it is full screen on my Surface Book Win 10 VNC client.


#31

After balancing the trade offs, I decided to stay with my 2 monitor setups for now, since my Rock Pi 4 normally uses 4.x watts and tops out at 8.5W, but every time I fire up my Intel 8086K+RTX 2080 next to it, it shoots up to 150W easily :sweat_smile:

I trade desktop space for electricity.


#32

Just finished my ‘maker’ station. Can’t part with the Surface Pro as the primary computer for internet banking, purchases, shopping, etc. Then, there’s the Rock Pi 4B, plus 2 RPi B3+ w/breadboards and a Pi ZeroW for downsizing end products.
Need to use VNC to reduce keyboards, mice, and TV inputs.

BTW, sorry to report that Debian arm64’s HDMI output wasn’t recognized by the new 4K Toshiba FireTV. Had to run Debian Stretch armhf, instead. This also resolved the issue I was having with playing audio in YouTube videos. Stretch allows me to set the rockchip,es…codec configuration to ‘Analog Input’ as the default. Chromium works with that setting on armhf.

Best regards :sunglasses::sunglasses:


#33

The HDMI and YouTube audio issue are strange, as l have been using both the whole time didn’t see any of them, I can’t even think of where to look.


#35

@TheHermit,

I installed TightVNC server this way: “sudo apt-get install tightvncserver” and it installed all the dependencies (including fonts) for me. In the past I’ve had to install the fonts after the fact. I quick Google search should let you know what to install. It’s a relatively easy fix. I run all my SBC’s headless.


pinned #36

Debian 下火狐(esr)用 apt 安装好了,但不能运行
#37

Re-installed Debian ARM64 and it works fine on the 4K TV, now. The only logical conclusion is that I’m too stupid to know which HDMI inputs the device was on during the initial setup. The TV is wall mounted, so the inputs are not visible.
Sorry for the false alarm, folks.
Unfortunately, I’m still having the same problem playing YouTube videos. Chromium videos only connect to the rockchip codec if it is configured as an output or duplex device (Pulse Audio Volume Control). When configured as such, with both HDMI codec and rockchip codec outputs, only the rockchip codec output shows volume level. HDMI codec output only becomes active whenever the rockchip codec is not configured as an output (or duplex).

On one hand, Chromium requires the rockchip codec to be an audio output to handle the audio signal. On the other hand, HDMI codec requires that it is not.

On the armhf build, Chromium will connect to the rockchip codec when it is configured as an input. As such, the rockchip codec doesn’t ‘take the output away’ from the HDMI codec. I suspect that this is an older version of Chromium, so that’s where I’ll start.
Any recommendations for alternative browsers on this build?

I also saw another post praising the YouTube playback performance on this build. The post mentioned some additional installations, which I will research.
Beyond that, I have to wonder about my router’s configuration, since I am apparently the only one having this issue.

Lot’s to do. Will keep you posted.
Thanks again (and again, and again…):smirk:


#38

I’ve never used HDMI audio output, the old monitor I used with RP4 has no speaker. I’ll tried out on my other monitor which has a small built-in speaker see how it goes.


#39

Wondered about that :slight_smile: Still, it’s difficult to imagine I’m the only one using HDMI.
Installed stretch and learned that Chromium is ver 63.0.3239.84. Did update/upgrade to ver 72.0.3626.122-1.
TightVNC server requires login after reboot, which has locked me out twice, now. Have changed ‘linaro’ password and given ‘sudo’ new passwd beforehand, but still get locked out. hmm… Linaro is not authorized to create new users or change group membership? How can I login with admin rights?

Anyway, now I’m on today’s second reload of stretch image and notice that Chromium is being ‘kept back’ from being upgraded. Has this been done by git-hub, only hours ago? Consistency would be very helpful.


#40

I changed the password too (always the first thing to do) and added new user then disabled Linaro. I didn’t had any issue, but changing hostname incorrectly did locked me out once.


#41

Got it… kinda. Now, I can only log in as ‘root’ w/new sudo passwd. I can add the ‘sudo’ service, but the ‘User Settings’ dialog box hangs on loading. Pulse Audio Volume, and Chromium stopped opening.

Time to re-image, again.:tired_face: