Need USB help on a Rock 3A

Just got a Rock 3A running on Debian 10 I’m using a wireless USB keyboard and mouse as input, and HDMI output to a TV as a monitor. So I know at least that USB port is working, but I can’t see any jump drives I plug into the other ports. I am extremely new to Linux and could use some help figuring out how to get these working. I have a Rock64 that had no issues with any of the OS’s I tried on it, IE: Android, Armbian, Manjaro. The USB ports initialized and worked at boot on the Rock64, I assumed they would on the Rock 3A as well. Thanks for any help.

This problem is not solvable even by kernel hackers, while “new to Linux” have exactly 0% chanches. Don’t worry about. This hardware is sold without working software … Support people that works hard to bring those devices up. That is the only thing you can do beside waiting.

Support for Rock3A is fairly new and it will get fully support as the drivers and soc support matures with time. Rock64 is a very matured soc so it have all the needed drivers to make use of all available USB.

For now you can use a USB hub in that single port which is working fine for you.
Once the supporting drivers are ready then you should be able to use all the other ports as well.

If you need it to work urgently then you can pay Armbian developers to bring up the needed drivers and maybe they can upstream it faster then the community contributors. :smiley:

PS do the submissions
Fix USB2 but 5.17 is still and RC as for “This problem is not solvable even by kernel hackers” its not been solved yet, or likely has been and just needs the next Linux release.
If so and works it may be backported until 5.17 is in the wild.

PS don’t donate instantly as think that was a touch of irony from Spiker as for those supposed Armbian devs the problem is not solvable until a kernel hacker supplies the solution, unless you want to use some hacked BSP for the rockchip EVB indefinately, if that exists.

One can buy fully working x86 device too. Or Rpi.

But video acceleration doesn’t work in mainline. How many years after hardware was introduced?

I would rather see you fix it - this is anyway the only problem you see. This is our end-users support contract since ever:

“Armbian is free software and provides best effort help through community forums. If you can’t find answer there and/or with help of general project search engine and documentation, consider hiring an expert.”

Our priorities and directions are not the same.


As you can see this forum is full of newbies and trolls.


Few examples on why your phylosophy disolves in realworld:

And another one - where it shows what happens after mainline kernel kamikazee fininshes their work:

Old stuff, lots of cash wen into … but doesn’t work.

That is very strange @igorp as it seems to be you consistantly trolling.

You have banged your head or something whilst completely destroying any reputation Armbian had.
I am not going to reply to you direct anymore as something has become unhinged and its sad to see.

Like in any context of this forum what is that supposed to be in terms of help or support?

We shall see with the boards of relevence in this forum to how they are supported, you can keep trolling tangential comments if you wish but I am not going to enguage unless it is about a current Radxa product.

1 Like

Armbian is a lot more than my personal opinions on forums.

After you will all use “Opinions expressed are solely my own and do not express the views or opinions of my employer.” … you will have some rights to complain.

Helping yourself, vendor, user or society?

“Those who cannot learn from history are doomed to repeat it.”

QED thanks for confirming.

igorp, that’s funny :smile: but actually I have several x86 laptops one running windows, one was running ubuntu, now manjaro, an Rpi 2b running Raspberry Pi OS, and a Rock64 running Manjaro. The latter runs great, hence the question was asked if anyone knows if an “official” Manjaro for the 3A was in the works. Thanks!

Just an FYI, I downloaded an “unofficial” (slarm64) OS and with it I see the thumb drives fine. Yet the “official” Debian release does not…Just sayin’…

1 Like

I think there is as its early works but manjaro are also posting to mainline

Alex Bee posted the above via Manjaro I think also a guy called Peter Geis seems very active as because of the mux on the RK356x you have to assign the mux before the USB so it not just the standard USB assignment but looks like that is done or being worked on as I posted that above.

I think manjaro are working on the Pine Quartz board as they got samples 1st or have a preference for but its a RK356x and likely I would hazard a guess.

You can usually find releases in

Yes I have worked on Rock3A already and it should have usb2 working fine. I have just not prepared a ready to flash image yet.

I will work on it tonight.

1 Like

It is, indeed :rofl:

Hey All,

Some early image of Manjaro ARM for Rock3A.

Available for download. Only 1 USB port is working.
Manjaro ARM - Rock3A - Dev - Beta - Unstable

Whats working:

  • HDMI out
  • HDMI Audio
  • UART
  • Lan
  • 1 USB2 Port
  • GPU (Panfrost)

Not working:

  • PCIE
  • USB3
  • Analog Audio

Test and share feedback.



Looking at Rock3A schematic I found that the other USB2 is connected via a hub FE1.1s_QFN24

So this might take sometime to be added to the dts.

Till then it is only 1 usable usb port.


So this USB hub cannot be detected directly by system? Strange.

If you look at on the block ref you will see a usb hub which is strange as it connects to pcie2.0 & USB 3.0 which makes me believe something is not right as that is more like serdes mux.

The serdes mux is shown here but as you can see it does say usb2 hub in the above?

So its prob going to take some time for spikerguy as yeah its strange and Radxa likely will have to give a bit more info.

One USB 2.0 signal on 40-pin header
According to the ROCK 3A SKU table, there are two USB 2.0 signal lines on 40-pin header, PIN 27&28.

When you want to select this USB function, you need to modify the hardware like this.

Remove R90526 R90527
Add R90536 R90537

Why its shown to connect to Pcie2.0 I dunno and why its there on gpio when it means adding and removing resistors which ended up on pins 27&28 is confusing.

I thought USB 0/1 where dual speed depending if you muxed the serdes and USB 2/3 where just straight but its a complex SoC with a new architecture from Rockchip.
I have to be honest as always been confused to what I thought the serdes mux and adoption would be as expected a DTB to select operation on boot but not to run concurrently.

The USB hub is connected externally using a fe1.1s chip. Serdes transceiver can be used for multiple modern communication ports, so they are shared by different devices.

Can you check if the second usb2.0 port is usable in other system images? I’ve just bought the board but they haven’t started delivering due to lunar new year holiday.