My zero Wi-Fi is not working

Zero is a 2GB RAM and 8GB emmc model.

I didn’t check if it worked correctly after the first purchase.
And I did a lot of work to install os in emmc.However, we decided to boot through the sd card if necessary.

But another problem arises.

The 1GB product I purchased had normal Wi-Fi operation.
It was normal no matter how many times I rebooted.

However, there is a problem with the 2GB product as shown in the attached picture below whether I damaged the board while working on emmc.

And only loopback appears when entering the nmcli command.

I tried a few ways to find a way in the relevant forum, but it didn’t work.

What I’ve done,

I changed the brcm43456.sdio.* file from /lib/firmware/brcm to brcm43456.sdio.radxa,zero.* file.

Debian and Ubuntu both have the same error.

Update :

It’s working normally right now.

sudo rmmod brcmfmac

sudo modprobe brcmfmac

After entering the command, I got Wi-Fi normally.

However, there is another problem when rebooting, so put those two commands in /etc/rc.local.
It was activated at boot time and it was confirmed that it was operating normally even after rebooting a few times.

My 2GB model also suffers from this bug. After downgrading to firmware version, it seems to happen less, but still happens from time to time.

I suspect it has something to do with this:

When using CoreELEC everything works as it should. Damn mysteries.

still no luck on my end. i did try most of the stuff i read about, its very frustrating for sure.
I got 4GB - 128GB eMMC version of zero as a second unit.
I’m having this Wi-Fi issue and couldn’t find any solution yet.

1 Like

Are you getting the same error as me?

There was a problem with flashing the os image on emmc, so I thought I would boot the sd card and solved it. I thought about it, but the Wi-Fi problem? If it’s a software bug, a new version that has been fixed should come out soon.

1 Like

With the 2GB model I’ve had the Wifi Issue on both eMMC and SD, with Radxa imgs and my own custom imgs. With the 4GB model all is working as it should for me.

I’ve also noticed other bits. The LED on the board doesn’t work the same on the 2GB, as it does on the 4GB. I suspect they are not the same hardware revision, although purchased around the same time and from the same place.

I’ve had no issues flashing to eMMC. Fastboot, rsync or dd’ing from sd to emmc all work.

I have this posting in another place too, but i think its connected, so i’ll include here too.

Im getting this errror @SKRSKR

Connection activation failed: (7) Secrets were required, but not provided

Then I checked for solution to fix it;

1st one didnt do much;

nmcli con delete <SSID>
nmcli dev wifi connect <SSID> password <password>

2nd didnt work too

  • Edit with sudo grants: /etc/NetworkManager/NetworkManager.conf
  • Add the next two lines:
  • Execute: sudo systemctl restart NetworkManager
  • Use your WiFi. :wink:

3rd attempt:)

I did factory reset on my modem & router. I thought maybe there was soo many connections or something else was going on.
but no luck…my other zero device works and connects.

new one doesn’t .

as a note i did turn on show password for wifi and entered that way to check if i was making a mistake. but i was entering correctly.

From what I can tell CoreELEC uses vendor code whenever possible while most other distros try to stay close to mainline kernel. That might be why.

@SKRSKR @gnlkrmz @c0rnelius I have produced a test kernel that synced mmc driver with the latest Linux source. Please check if this helps with your issue. Be aware this is for our Debian/Ubuntu system only.

I’ll try it on my system soon.

If it’s a test kernel, how can I restore it to a normal kernel afterwards?

sudo apt remove linux-image-5.10.69-999-amlogic && sudo reboot

Yes but you are using wrong image. Make sure the filename start with exactly radxa-zero.

Yes, sorry i entered the wrong one. I downloaded the zero version.

I’ve downloaded this version: @RadxaYuntian


I’ve tried the install run

Meson MMC Sync

I got this error - maybe i did a mistake not sure.

My version

Well you need to download the kernel from that release page first. Try wget then follow the instruction on the release page.

If you are missing wget run sudo apt update && sudo install wget.

Are you referring to the most recent changes made here?:

They would appear to be commits already made in 5.15 and 5.16. I’m currently running 5.16.10. I checked ur other branches and didn’t see any other relative mmc commits.

Im new with Linux, thanks for explanation.
By the way seems like i have to download but i dont have connection (considering the problem we are trying to resolve)
I will try to copy it to zero and run that way…

I did the update, but i got the same error as before. No wifi connection.
Including screenshots below for your review. @RadxaYuntian


@SKRSKR did you had chance to give a try on this ?

Can you post your sudo dmesg after getting the secret error?

1 Like