Introduce ROCK 5B - ARM Desktop level SBC

Guys, someone has installed Ice cooler or a good cooler like in Firefly mobo to put Android OS and Overclock it with Franco Kernel Manager? I’m very interested if it’s boost 3588 up to 40% .
Unfortunately nobody of YT channels got this idea. If someone get Rock5B (i still didn’t receive 50$ discount) can post the Geekbench screenshot :yum:.
P.S. or was already did? Taki Udon and Eta prime showed GB5 SC value of 550, while on this forum and posted then on CNXsoftware showed a value around 643…

Works far better than the passive blue fan without a fan as due to the adjustable mounts its actually more central and covers the cpu and doesn’t need a thermal pad hack as it lies flat with standard grease.
Stress-ng maxes out out 75c as passive and doesn’t throttle with a fan your never really above 45c
With a fan its pure epic but likely the fan supplied as I got one without (prob stupid as the screws are also important) the 5v is going to need the right fan header. It will never get above 45c with a 12v on 5v @ approx 46% constant.

Ended up with some of these but actually just lazy and have a 12v 40mm on gpio ontop. So if you are lazy like me get a 12v fan that will run silent on gpio 5v or get a 5 v and chop and fit the right header as ZH 1.25mm 5v 40mm fans just seem hard to find.
If I wasn’t lazy I would fit a 5v as with this heatsink it really doesn’t need a fan so it can be off whilst 12v is permanently on.

@Oneofmany888 you will not be able to overclock as the debug party have already tried. Due to they way it works even a mild volt increase an OC just makes it go hot.
They gave in so don’t try as you will fail

1 Like

Hi all, did anyone get the TTL/serial console to work on boot, I am trying to make it work and it does not work on first try. I made a thread about it here: Which pins should go to TTL cable on the Rock5B?

just swap tx and rx it cant brake anything

Hi all so, the serial console works - great. Now the next question is this How make Rock5B's 22x30mm M.2 PCIe slot work on Linux? . Do you have any thoughts?

delete this post

you can just delete it by pressing the three dots and then the trash icon and it will be gone in 24 hours

those adapters are just problematic, You need reader that support it and none of build in pcie sd card readers are working with them, just get usb hs200 adapter - that one is far better than anything else.

1 Like

Thanks, I did end up getting it working after all
I dug out literally the oldest USB to micro SD adapter I had, USB 2.0 one that came with my Supercard DSTWO (DS flash card)
finally Windows recognized it but first time writing the image it failed though , Balena etcher failed during verification.
It took me forever to get the EMMC cleared off, on the second attempt it said it wrote it successfully.
I haven’t tested it yet though, I had to use Aomi to delete all the partitions
and it was problematic, I don’t even know how I got it back to showing the full space.
but afterwards it still would not show up anywhere in windows, not in file explorer or in disk management, but it did show up in Balena etcher, I formatted it as FAT
so was that right? or should I have formatted it as exFAT?
hopefully it will boot and the rest of the space will be useable in Android.
what a PITA it is to clear all those partitions after a failed write ,unless there is an easier way than I did it, there probably is.

Using this adapter is plain pain - not only it does not work for most of modern card readers but it’s also terribly slow. Balens shows block devices, not partitions, that are created from images. If You need to see it on windows now - use fdisk from command line to clear everything. If You plan to use it on linux - just re-burn it with balena.

BTW: I don’t know where You want to use that eMMC but probably You have already some sbc with eMMC socket. Still You can boot from sd card and burn image at high speed straight from linux. HS400 vs this adapter is about 100x faster.

Well I got it working , the time wasn’t that bad, it too about 10 minutes to burn Android rk 12 , and another 10 minutes to verify it.
it is very flaky though ,

my rock 5b is no longer stuck (it stayed at the border point for about 2 weeks) now it is in swizzerland:

the destination is percha italy

Well Khadas distributive of ubuntu with gnome desktop has old kernel without intel wifi 6e, ethernet and nvme support, so it isn’t useful. For me - ubuntu gnome desktop with wayland it is normal case. Now official radxa Ubuntu 20.04 server updated to 22.04 and installed with ubuntu-desktop not support video acceleration (eats processor in every movement of window), board boil very much (including nvme and m2 wifi modules), hdmi input unavailable too. Debian official distributive has low perfomance and artifacts on screen rendering.

One question.
Does the Rock5 support doubled-sided SSDs? (3.5mm thickness)

yes the slot is a standard slot so it shold be ok

1 Like

tried a nvme with sabrent rocket heatsink, it touches some squared electric component.

what squared electric component? what color? how many contacts? a picture maybe? and where is it touching? where is it on the rock 5b? is the part of the ssd thats touching conductive?

shill, i’m not your pet

the backplate of the heatsink is bending, not an issue to me. i was more worried about the connector being to close.

this is only a coil so no problem but i recomend removing the yeatsink and backplate from the ssd because it could damage the ssd (but if you dont want to remove it it sould work anyways)

mine finally arrived in Sydney Australia

I slapped the latest rolling ci Armbian image on a microsd/tf card and it booted up fine with this zyron usb pd charger I got off ebay. It’s definitely a fast soc compared to just about any other devboard, the i/o flows easily, the ethernet does 2.5g, even the tf slot writes 40 megabytes/s on the netac 250gb card I have in it currently. I tried stressing it out with ffmpeg software encoding, no heatsink, and it crashed. So I dug around and found an old Thermalright HR-05 Northbridge Cooler and it popped straight on very easily, so I added some paste and off I went, stress test no longer crashing it, been running for 5 hours or so now and CPU temp is 49C

I have the metal case on pre-order from ameridroid but i’m thinking maybe something more open might be better and keeping this heatsink on it permanently might not be such a bad idea

So far the only major thing i’ve stumbled on that’s a bit concerning is the bottom USB3 port appears to be less stable/limited in some way than the top USB3 port at least with this Armbian build. Basically when plugging in a rtl8153 or ax88179 1gbe ehternet adapters it doesn’t take long to have them crash running iperf but they work flawlessly in the top port straight away. So far it seems like the bottom port may be safe for storage, but network adapters maybe stick to the top port. I may be totally wrong on this and just bumped the board in testing or something i’ll have to confirm more later.