Installation of SATA HAT software fails under raspberry pi os 64bit, SOLUTION: Update python setuptools manually

Hi, this is my first post, so I would like to say thank you to all the others here on the board.

I’ve tried to install the SATA HAT software on rasberry pi os 64bit as described on the wiki. First time I realized that the rockpi-sata-service wasn’t running. After some investigating I found out, that there was an error during the installation (see log file at the end of the post).

SOLUTION: Install and update the python package “python3-setuptools” to the latest version manually:

sudo apt install python3-setuptools
pip3 install - - update setuptools

Afterwards I run the Installation script again and everything went fine.

P.S. Under raspberry pi os 32bit there is another error while installing the software. I have no solution for that error. I’ve written an email to the suport of radxa regarding both errors.

Good luck

log file for first installation attempt

*** Quad SATA Hat Install for Raspberry Pi 3B+/4B+

*** Tested distributions:
*** Raspbian buster 32-bit/64-bit(testing)
*** Ubuntu Server 20.04 armhf and arm64

*** Please report problems to and we will try to fix.

running install
running bdist_egg
running egg_info
creating Adafruit_SSD1306.egg-info
writing Adafruit_SSD1306.egg-info/PKG-INFO
writing dependency_links to Adafruit_SSD1306.egg-info/dependency_links.txt
writing requirements to Adafruit_SSD1306.egg-info/requires.txt
writing top-level names to Adafruit_SSD1306.egg-info/top_level.txt
writing manifest file ‘Adafruit_SSD1306.egg-info/SOURCES.txt’
reading manifest file ‘Adafruit_SSD1306.egg-info/SOURCES.txt’
writing manifest file ‘Adafruit_SSD1306.egg-info/SOURCES.txt’
installing library code to build/bdist.linux-aarch64/egg
running install_lib
running build_py
creating build
creating build/lib
creating build/lib/Adafruit_SSD1306
copying Adafruit_SSD1306/ -> build/lib/Adafruit_SSD1306
copying Adafruit_SSD1306/ -> build/lib/Adafruit_SSD1306
creating build/bdist.linux-aarch64
creating build/bdist.linux-aarch64/egg
creating build/bdist.linux-aarch64/egg/Adafruit_SSD1306
copying build/lib/Adafruit_SSD1306/ -> build/bdist.linux-aarch64/egg/Adafruit_SSD1306
copying build/lib/Adafruit_SSD1306/ -> build/bdist.linux-aarch64/egg/Adafruit_SSD1306
byte-compiling build/bdist.linux-aarch64/egg/Adafruit_SSD1306/ to SSD1306.cpython-37.pyc
byte-compiling build/bdist.linux-aarch64/egg/Adafruit_SSD1306/ to init.cpython-37.pyc
creating build/bdist.linux-aarch64/egg/EGG-INFO
copying Adafruit_SSD1306.egg-info/PKG-INFO -> build/bdist.linux-aarch64/egg/EGG-INFO
copying Adafruit_SSD1306.egg-info/SOURCES.txt -> build/bdist.linux-aarch64/egg/EGG-INFO
copying Adafruit_SSD1306.egg-info/dependency_links.txt -> build/bdist.linux-aarch64/egg/EGG-INFO
copying Adafruit_SSD1306.egg-info/requires.txt -> build/bdist.linux-aarch64/egg/EGG-INFO
copying Adafruit_SSD1306.egg-info/top_level.txt -> build/bdist.linux-aarch64/egg/EGG-INFO
zip_safe flag not set; analyzing archive contents…
creating dist
creating ‘dist/Adafruit_SSD1306-1.6.2-py3.7.egg’ and adding ‘build/bdist.linux-aarch64/egg’ to it
removing ‘build/bdist.linux-aarch64/egg’ (and everything under it)
Processing Adafruit_SSD1306-1.6.2-py3.7.egg
Copying Adafruit_SSD1306-1.6.2-py3.7.egg to /usr/local/lib/python3.7/dist-packages
Adding Adafruit-SSD1306 1.6.2 to easy-install.pth file

Installed /usr/local/lib/python3.7/dist-packages/Adafruit_SSD1306-1.6.2-py3.7.egg
Processing dependencies for Adafruit-SSD1306==1.6.2
Searching for Adafruit-GPIO>=1.0.5
Downloading …
Best match: Adafruit-GPIO 1.0.5
Writing /tmp/easy_install-9sefr4o8/Adafruit-GPIO-v1.0.5/setup.cfg
Running Adafruit-GPIO-v1.0.5/ -q bdist_egg --dist-dir /tmp/easy_install-9sefr4o8/Adafruit-GPIO-v1.0.5/egg-dist-tmp-xic2v5r0
zip_safe flag not set; analyzing archive contents…
Moving Adafruit_GPIO-1.0.5-py3.7.egg to /usr/local/lib/python3.7/dist-packages
Adding Adafruit-GPIO 1.0.5 to easy-install.pth file

Installed /usr/local/lib/python3.7/dist-packages/Adafruit_GPIO-1.0.5-py3.7.egg
Searching for adafruit-pureio>=1.1.5
Downloading …
Best match: Adafruit-PureIO 1.1.5
Writing /tmp/easy_install-tcbefcz6/Adafruit_PureIO-1.1.5/setup.cfg
Running Adafruit_PureIO-1.1.5/ -q bdist_egg --dist-dir /tmp/easy_install-tcbefcz6/Adafruit_PureIO-1.1.5/egg-dist-tmp-873slmil
/tmp/easy_install-tcbefcz6/Adafruit_PureIO-1.1.5/.eggs/setuptools_scm-6.3.2-py3.7.egg/setuptools_scm/ RuntimeWarning:
ERROR: setuptools==40.8.0 is used in combination with setuptools_scm>=6.x

Your build configuration is incomplete and previously worked by accident!

This happens as setuptools is unable to replace itself when a activated build dependency
requires a more recent setuptools version
(it does not respect “setuptools>X” in setup_requires).

setuptools>=31 is required for setup.cfg metadata support
setuptools>=42 is required for pyproject.toml configuration support

Suggested workarounds if applicable:

  • preinstalling build dependencies like setuptools_scm before running
  • installing setuptools_scm using the system package manager to ensure consistency
  • migrating from the deprecated setup_requires mechanism to pep517/518
    and using a pyproject.toml to declare build dependencies
    which are reliably pre-installed before running the build tools

zip_safe flag not set; analyzing archive contents…
Moving Adafruit_PureIO-1.1.5-py3.7.egg to /usr/local/lib/python3.7/dist-packages
Adding Adafruit-PureIO 1.1.5 to easy-install.pth file

Installed /usr/local/lib/python3.7/dist-packages/Adafruit_PureIO-1.1.5-py3.7.egg
Searching for spidev==3.5
Best match: spidev 3.5
Adding spidev 3.5 to easy-install.pth file

Using /usr/lib/python3/dist-packages
Finished processing dependencies for Adafruit-SSD1306==1.6.2
Selecting previously unselected package rockpi-sata.
(Reading database … 36209 files and directories currently installed.)
Preparing to unpack /tmp/tmp.x7AWKeN2Bx …
Unpacking rockpi-sata (0.14) …
Setting up rockpi-sata (0.14) …
Created symlink /etc/systemd/system/ → /lib/systemd/system/pigpiod.service.
Created symlink /etc/systemd/system/ → /lib/systemd/system/rockpi-sata.service.

1 Like

I literally /just/ did a full rebuild over the last few days and experienced no such issue.