Install fails on Raspberry pi 4B

Hello all,

i have been trying to re-install my Quad Sata Hat in my RP4B

but i am encoutering setup problems after i run the install script

curl -[removed so i can post]… | sudo -E bash -

then i get the following errors at the end of the run

Searching for adafruit-pureio>=1.1.5
error: Download error for https://s3.setq.ip/rockpi/pypi/ [Errno -2] Name or service not known
(Reading database … 40574 files and directories currently installed.)
Preparing to unpack /tmp/tmp.HWL6mFHbUB …
Removed /etc/systemd/system/
Unpacking rockpi-sata (0.14) over (0.14) …
Setting up rockpi-sata (0.14) …
Created symlink /etc/systemd/system/ → /lib/systemd/system/rockpi-sata.service.
sh: 0: getcwd() failed: No such file or directory
sh: 0: getcwd() failed: No such file or directory
sh: 0: getcwd() failed: No such file or directory
sh: 0: getcwd() failed: No such file or directory

I Tried to download the file from the url (Download error for https://s3.setq.ip/rockpi/pypi/ and it was indeed a dead link

Thanks for the help in advance

1 Like


I downloaded the necessary files before, I put them to my Google Drive:

You can find every file which would be needed.
You have to unzuip it manually and run the commands.

If I remeber right: unzip it manually, cd into the directory and run:

python3 install (copied from the installer script)
I got error, because of less permission, so I could install it with:
sudo python3 install

Good luck!


Thank you

i will try this out and update this thread :smiley:

1 Like

Thanks for the help. setup worked really well

my OLED panel is now working

Thank for the help

1 Like

hi,How did you solve this problem?
I didn’t know how to solve this when I started the installation yesterday

I don’t know the relevant knowledge of linux,
Don’t know how to manipulate these files

@SagittaLuminis Sorry, the installation script had a typo URL, it has now been fixed. Please try again.

I’m confused,

input this command curl -sL | sudo -E bash -
The board rebooted ,lcd is working ,fans and SSD working,but i ……cannot access

You can’t access to your files on the devices directly.
You have to mount the partitions into folders.

  1. List the devices name to find out what you have to mount with lsblk or sudo blkid (or get them from /dev with ls -l /dev):
    sudo blkid

My output is:

/dev/mmcblk0p1: LABEL_FATBOOT="boot" LABEL="boot" UUID="F4F1-BC2C" TYPE="vfat" PARTUUID="848e22bd-01"
/dev/mmcblk0p2: LABEL="rootfs" UUID="163660a6-ad17-44fc-99c5-5c75e78ad815" TYPE="ext4" PARTUUID="848e22bd-02"
/dev/sda1: LABEL="Torrent2" UUID="96747358-15eb-4377-b287-8d7ce014a232" TYPE="ext4" PARTUUID="66ab17ec-01"
/dev/sdb1: LABEL="Torrent" UUID="a162b11d-43aa-4632-8986-dd11ab496b06" TYPE="ext4" PARTUUID="c355b33b-01"
/dev/sdd1: UUID="2a45581f-c661-e90d-3308-2491dc77df35" UUID_SUB="ca79ed01-898d-0ce8-6ad5-022b188dae67" LABEL="raspberrypi:0" TYPE="linux_raid_member" PARTUUID="85656a83-01"
/dev/md0: UUID="2cf5b171-9ca7-4f1b-bcf8-e19b31ab3dc4" TYPE="ext4"
/dev/mmcblk0: PTUUID="848e22bd" PTTYPE="dos"

We want to mount the device with labelled by “Torrent”. This name is sdb1.
(sd came from is the SCSI disk, after the ‘b’ means this is the second detected sd device (sda, sdb, sdc, sdd, sde, …) and number means the partition number. So sdb1 is the second recognized HDD/SSD and the first partition we want to mount.

  1. Create a new folder into /mnt with name eg. Torrent:
    sudo mkdir /mnt/Torrent

  2. Mount the selected partition of device:
    You can specify the partition type with -t parameter, but mount tries to find out automatically, see: mount(8) - Linux man page
    sudo mount /dev/sdb1 /mnt/Torrent

  3. Now you can access to your files:
    cd /mnt/Torrent

  4. List the content of the partition:
    ls -la

You can do auto mount, but it’s another story.
Try this first, and let me know whether it was successful.

The HAT is now working properly with only one HHD installedIs 。
There a case or tutorial for installing Transmission on HAT。I follow other transmission installation tutorials to operate, all kinds of errors or failures, probably related to the mount point of the device

I am using qBittorrent and I had to edit systemd service to wait for the partitions mount.
If they mounted, it can start.

I suggest to this one: This is the issue with the quad sata hat and raspbian

Finally, I gave up installing transmission and installed qbittorrent instead.
Now how can I change the default file saving path。

Maybe I should try setting mount point or soft link or something?

Thank you for your prompt, I tried to add /dev/sda1/downloads as the file save directory. No permission (Permission denied)

Then I tried to use /srv/dev-disk-by-uuid-58b29310-8a17-4444-a25b-d93bb132e951 as the path, and finally qbittorrent can be used normally

Super excited and thank you !


You have to add the mount point, not the device directly.

You have to imagine the mount point like a drive letter on Windows.
Eg. /mnt/torrent is the D:\ and /mnt/torrents/Downloads is the D:\Downloads
So that mount point folder will be your loaded device partiton.

I am glad you could made it!
You can always check your mount points with df -h or lsblk commands.