How to start the device while back-powering via GPIO?


I’ve a Raspberry Pi 4 with a dual SATA HAT, and I’ve a 12V/5A DC jack 5.5x5.2 mm PSU. I think I’ve assembled the system correctly, but “nothing happens”. (I haven’t actually tested the PSU, but I’ve tested the rpi board, it boots from SD correctly.)

Could someone point me to the right direction on how to proceed in this situation?

Thank you for your help in advance!

Hello, what do you mean “nothing happened”?

Did you install the software that comes along with the hat? See the wiki pages.

Also: You need to power the RPi and the HAT from the barrel socket/USB-C on the HAT, not via any other GPIO work-around.

Thanks for the fast replies!

Literally, I plugged in the barrel jack into the barrel socket on the HAT, and none of the LEDs blinked, the connected HDDs did not started spinning, the rPi’s RJ45 port did not start blinking either. I listened to the PSU too, but there was none of the usual high-frequency buzz either.

I did not install any software yet. (Just a stock Raspbian.)

You need to power the RPi and the HAT from the barrel socket/USB-C on the HAT, not via any other GPIO work-around.

I’m trying to :slight_smile: The SATA HAT connects through the 40-pin GPIO header, right?

Barrel socket is the way to go.
Plug-in your power supply with the hat removed from your RPI and without any disks. At least the PS led should come on. If not first look at your Power supply, and make sure it works ok.
If that’s ok: power the hat with disks only inserted, Start with 2, then 3 or 4
What disks are you using? And what are their power supply ratings?

If all that is ok and your RPI boots: install the software. It is needed for the sata chip(s) to be enabled and thus make the disks come alive.


Better late than never, right? :slight_smile:

So, I got a voltmeter (and time to get back to working on this, the meter was already on the shelf) and tested the PSU. 12V DC in the barrel connector.

I plugged in just the HAT, no light. I tried to poke around with the meter and there was no 5V anywhere relative to ground on the GPIO header pins.

I’ve assembled the rPi4 + HAT (no disks) and plugged the power into the HAT. No LED activity. :confused:

I’ve tried the same thing after running the install script, same result.

It looks completely broken. Please try contacting ALLNET China to see if it can be replaced or repaired.

Thanks for the fast reply! (I bought it via Distrelec, but I’ll try to contact ALLNET. Thanks!)

Hey again :slight_smile:

I’ve ordered a new one (quad SATA this time!), and it arrived amazingly fast!

But it has a different DC jack. Based on the PSU sold on ALLNET China, it seems to be a 5.5 x 2.5 mm, right? What’s the required voltage and power? The text on the PCB is RA005-Q(D)F4-V1.4 2020-09-17

Also it’d be good to edit the wiki page too: ^^

Need 12V, and you need more than 3A.

Thanks! Do you happen to know the dimensions of the DC jack? It’s different from what the previous one has, and there’s nothing about it on the site.