How to access the drives

I recently recieved the quad SATA-kit and I’m having problems with accessing/using the drives.
I installed the software using “curl -sL https://rock.sh/get-rockpi-sata | sudo -E bash -” according to https://wiki.radxa.com/Dual_Quad_SATA_HAT. When I install the software or start my rpi all the LEDs light up but then they turn off again. If I restart the rockpi service they light up but go black again.The OLED and fan on the top never start from what I can see.

If I use “systemctl status rockpi-sata.service” I can see the drives but I cant access them.

I’ve tried fdisk -l but I can only see the SD-card.

Hi ariex,

Please replug the hard disk and USB connector, the contact may be bad.

Hi,

Since the drives show up and the LED’s turn blue everytime i restart the software it doesn’t feel like its a problem with the connection but I will try that when I get home just to be certain.

Do you have any other tips?

Poor hard disk contact maybe cause this problem.

We tested each SATA HAT three times before sending it out.

I have now tried to dissasemble everything and then reasemble it but I still have the same problem.
Currently I’ve tried to boot with the following just to make sure it wasn’t my Power Supply that gave to little power:
4 2.5" HDD’s
1 2.5" HDD
1 2.5" SSD
2 2.5" SSD’s

But I always get the same problem… The software “kind of” find the drives but I cant do anything with them. How did you do your software raid?
Which OS do you use?

Note: the top fan/LED doesn’t seem to work either.

rockpi-sata.service just let hat power-on via set the value of gpio. It doesn’t do raid.

The OLED and fan are not working maybe because the 2*5pin cable is broken.

Because top-board don’t work, this triggers a bug in the software.

Due to my negligence, I didn’t find out when I tested.

I will fix it as soon as possible. Thank you for your help.

As for top-board not working, we may ask the seller to send you a new cable.

Edit:
I fixed it. Please reinstall it.

1 Like

I reinstalled it and now I can access the drives! :slight_smile:
Thank you for fixing it

Do you know what kind of cable it is? (Might find it in a store here since its quite the transport to Europe)
Or who do I contact for the cable and some new screws since the one attaching the Sata-hat to the rpi4 where to big?

Cable: PHD 2.0mm 2*5pin
Screw: m2.5 pillar, m2.5 screw

You can find them through Google, but I don’t know where you can buy them.

1 Like

Unfortunately I could not find any reseller of the cables thtat could sell less than 100 unless it was from China. Also having issues that the USB-C cable I bought doesn’t work through the chassi because its to thick. I assume I should contact Allnet China about it?

Yes, please contact AllnetChnia to send you another cable.