Freezing Rock 5B with Rsync transfer

Known problem on some boards:

But that this happens with rsync is somewhat strange? Can you test through sbc-bench -s walking through the DMC frequencies from bottom to top? At which RAM clock is your board freezing?

Will this also be remembered if rebooting the device? do we need to set governor userspace and how?

I also had to reduce cpu frequency sigh. Was this hardware ready when it launched?? (yes i bought mine as some of the early models) I mean happy it seems to be working so far but kinda sad most of my HW must be run outside of specs to be able to function.

1 Like

Hmm I said that too early even lowering to 2ghz it crashed when using WinSCP same time I was trying to browse a plex server.

update: with latest debian image it is crashing still but it seems its able to reconnect every time some seconds later at least so not a full network shutdown anymore. This is using the official raddax power supply so not sure if that has helped too.

Also if it is helpfull I transfered a few books I have bought from humblebundle on a another rock pi 5b using calibre web and this did not fail a single transfer. I am wondering if it is related to larger files and that it is then related to some memory problem? But why would it then shut down the network ?

hey there,
this problem still persists !
I’m using a 65Watt power supply and also added a heatsink around the nvme …
network ping is still answering, but the rock5b is not accessable anymore.
this is a hard problem, I bought this to replace my raspi 4.
but with this performance issues … no way .

1 Like

Have you tired this method

Limiting RAM frequency improves stability for me and stops the random hangs/reboots:
echo 1560000000 | sudo tee /sys/ class / devfreq / dmc / max_freq

Known problem on some boards:

Today I was down to 528MHz, the upload with winscp survives a little longer, but after about an hour the rock5b died again….
could someone try it on their machine to reproduce it and maybe find a solution?

just to add, I have a rock5b with 32GB ram and a samsung 980 1TB NVMe. also tried different OS with different kernel versions.
looks like, if I limit the upload to 1MBit/s it works ….
But the rock5b has what, 2.5GBit ethernet …

It might be the SSD. 980s are quite power hungry and Rock 5b was reported to hang when using them. Try using a less top of the line SSD and it will never hang any more.

Hi There, you may want to try this: Radxa Rock 5b Hangs multiple times a week

BTW: Depends on which win version you are using but in my win 11 i can use scp from terminal without needing putty / winscp.

Now after testing and try and and …
I monitored the system all the time an now I found this.
if the RAM Cache + Buffer metrics reaches 10.3 GiB it freezes. It’s reproducable. Now I need an idea how to overcome this border

If I cleanup the buffer / cache if it reaches 10GB … the rock5b will survive … he’s not freezing …
so maybe my memory is faulty or something else.
I will contact the supplier and ask for a new one …

Maybe others with this issue can try to reproduce it ?!
and give a feedback

Try running memtestfor some time,
Try same thing with additional cooling, About year ago I had such issue with my nuc box, I added more RAM and it started to work unreliably. I found out that two RAM modules will heat up and then they are not that stable, same thing with additional fan solved that issue.

@Christoph_g @eysteinh


This may be the same problem, where we found the solution.

So be sure to update the SPL bootloader on SPI-NOR, even if you are booting from another medium.


as I can reproduce this issue with
„memtester 15000M 3“
with all tested OS‘ , I think it‘s hardware related… and I was able to catch this

any further ideas?

is there a bootable memtest86 für rock5b out there, everything I tried failed booting from sdcard and usbstick…

Have you even tried flashing spi-nor?

in regard to your howto? yes I did, but after that I wasn‘t able to boot anything. I had to recover the boot sector. so i guess I did something wrong….

I‘m not sure if I did everything right when running through your howto.
maybe you can provide it in a personal message or mail in german.?

Check your pms :partying_face:

this solved my problem,
As I was in contact with radxa support, I told them they should have a look into this post to provide the SPI on their homepage.
Big Props to the guys who found this solution at write the howto for the medium skilled once :smiley:

1 Like

same issue here: in my case I’m just performing an apt upgrade with official image, to be more precise a “sudo dpkg --configure -a” after an interrupted “apt upgrade”. I also tried to launch these commands inside a screen session, when I go back via ssh it says “no screen to resume”.

uname -a
Linux apollo 5.10.110-15-rockchip #a2d3d7e5d SMP Mon Sep 4 11:55:03 UTC 2023 aarch64 GNU/Linux

at the end of dmesg I have this, I don’t know if it is enough and I don’t know if bluetooth may cause this since it is connected via ethernet cable:
[ 7.581783] rk-pcie fe170000.pcie: PCIe Link Fail
[ 7.581802] rk-pcie fe170000.pcie: failed to initialize host
[ 7.608441] rk-pcie fe150000.pcie: PCIe Link Fail
[ 7.608458] rk-pcie fe150000.pcie: failed to initialize host
[ 7.608703] rockchip-pm-domain fd8d8000.power-management:power-controller: Looking up pcie-supply from device tree
[ 7.608721] rockchip-pm-domain fd8d8000.power-management:power-controller: Looking up pcie-supply property in node /power-management@fd8d8000/power-controller failed
[ 7.751716] mali fb000000.gpu: Loading Mali firmware 0x1010000
[ 7.752381] mali fb000000.gpu: Mali firmware git_sha: 9b8db9aa05a7b4f3066fd75dbdff695262f891fe
[ 7.902214] ttyFIQ ttyFIQ0: tty_port_close_start: tty->count = 1 port count = 2
[ 9.225174] Bluetooth: hci0: command 0xfc18 tx timeout
[ 9.729717] r8125: enP4p65s0: link up
[ 9.729746] IPv6: ADDRCONF(NETDEV_CHANGE): enP4p65s0: link becomes ready
[ 17.328701] Bluetooth: hci0: BCM: failed to write update baudrate (-110)
[ 17.328742] Bluetooth: hci0: Failed to set baudrate
[ 19.462295] Bluetooth: hci0: command 0x0c03 tx timeout
[ 27.355287] Bluetooth: hci0: BCM: Reset failed (-110)

I tried to reduce the memory frequency but no way. I tried to use only official parts and os to avoid compatibility issues, I wouldn’t expect so much instability.

If you need further information let me know.

UPDATE: I saw why screen or nohup launched dpkg won’t survive, I connected my rock5 and I run the same command directly from radxa desktop, at some point the device gets rebooted and the login screen appears again.

So it does look like the same problem. Did you update SPL loader on spi?

1 Like