Failed to start Rockpi SATA Hat Armbian 22.02.0 Bullseye (Please Help)

Hi all,
Rockpi SATA Hat service cannot start
(Fan is running in full speed + Led screen not working)

Failed to start Rockpi SATA Hat
rockpi-penta.service: Failed with result ‘exit-code’
rockpi-penta.service loaded failed failed Rockpi SATA Hat

RockPi 4C + ROCK Pi Penta SATA HAT
Armbian 22.02.0-trunk.0003 Bullseye with Linux 5.15.29-rockchip64 + OMV 6.0.18-1

Any solution or workover to resolve this issue

Hello, where did you download your image?

You mean Penta SATA software
curl -sL | sudo -E bash -

The armbian image

Really, I’m not sure wich site.
but this site is not working now ( Access to was denied )

Yes, it doesn’t work.

Then I will use Armbian_22.05.0-trunk_Rockpi-4c_bullseye_current_5.15.27_minimal to test.

Download from here:

Ok, I will try it and update you.
Thanks for your great help :+1:

Maybe there is something wrong with our APT and we are maintaining it.

What dose APT mean ?


I am installing armbian to test the script.

I tried radxa-build for rockpi-4c
( Armbian_22.05.0-trunk_Rockpi-4c_bullseye_current_5.15.27_minimal.img.xz )

but same error : rockpi-penta.service loaded failed failed Rockpi SATA Hat

I’m sorry that bullseye does not have libmraa at present, we are supporting it.

You need to use buster or focal.

Dose not supprt OMV installation

Can you please send me link of working buster or focal to download


What is root username & password

username root and password 1234