eMMC compatibility for "ROCK 3a" and "Rock pi 4"

this chip is a ldo , just to convert 3.3V to 1.8V

emmc chip need two voltage input, 3.3V and 1.8V

I found some photos of such adapters with and without this chip so I’m not sure if it’s required or not :confused: Any other idea what should I check on this adapter? I checked contacts on bottom and few slots (with and without sd adapter) and no luck :frowning:

if you want to use emmc chip as sd/tf, you must have both 3.3v and 1.8v supply.
you can read the datasheet of emmc chip.

The 3.3V to 1.8V LDO is not needed since the eMMC running in SD mode only requires 3.3V.

The eMMC module are compatible with ROCK 3A, ROCK Pi 4, ROCK Pi E and ROCK Pi X(early version).

1 Like

Jack - do You have such uSD eMMC adapter? should it work with eMMC just like uSD card? I’m trying to figure out if it is defective or am I missing something. - I got it working!
Also can I do anything to reset my second eMMC? One just work and one is not :frowning: is there any test software I can try? the only clue I have now is that dmesg error :frowning:

We have seen report that the eMMC to uSD doesn’t work on some Dell laptop. You can try to change to use it on a uSD to USB reader.

I actually edited that question - today I found odroid thread about same issues: https://forum.odroid.com/viewtopic.php?f=53&t=2725
I used yet another card reader (usb-c/microSD) and that one worked, it is terribly slow :frowning: I expected to use it with eMMC just like raspiKey. Yes, thinkpad sdhc reader is not compatible as well as two others I tested earlier. The one I used now works, but it’s 6-8x slower :frowning:

here are benchmarks:

no much better with cheap usb to eMMC adapter for rockpro64:

any cheap micro SD card is way faster:

of course on rock3A it’s different, I will try to find some better microSD readers and reply tests with this adapter I hope to be somewhere at 90MB/s with good reader :slight_smile:

To get the most of the eMMC read/write speed, use Radxa USB3 eMMC reader, it’s the only one on the market which support HS400 mode, the reading speed is more than 250MB/s on 32G/64GG/128G eMMC. Unfortunately the chip GL3227E supply is really bad that we can not manufacture it at the moment.


I expected that it would be slower, but not that much. Especially usb rock pro usb adapter is very disappointing with dedicated modules. Of course its way better on rock 3. I’ll get that raspi key for comparison.
Allnet still has this GL3227E usb adapter, it will take some time for delivery.

I repeated tests today with transcend uhs-ii reader, uSD adapter worked and speeds are way better:

this makes that adapter somehow usable,
My built in card reader is Lenovo RTS525A PCI Express Card Reader [17aa:225f], it’s uhs-ii pcie reader/writer on realtek chip, probably it can be found on other computers and some accessories may be incompatible. This may be same thing as in dell computers.

I managed to get GL3227E adapter and repeated my tests.

For foresee its bit better than fast uSD:

SiliconGo was bit better:

And sandisk eMMC is much better:

This is still not that fast as nvme but with right adapter it’s 30x faster than my worst benchmark.

Is Rock 3a compatible with eMMC module v1.2?

I have 3 such modules and each gives an error:

=> mmc dev 2
MMC error: The cmd index is 0, ret is -110
mmc_init: -110, time 33

Sorry to bring up this topic. I am a beginner with radxa boards.

UPD: Yes, they are compatible. I managed to make it work, but it’s more like a randomly cast magic spell.

What did you do to make eMMC work?

I posted photos of such module on the top of this thread and it’s 1.2, so yes - they work perfectly.

I had no problems at all with them on any board. What makes it hard for You?

eMMC don’t require anything in SPI and it should just boot with correctly burned image,
I guess that it was just not flashed correctly.

1 Like

Hello everybody. Few days ago i bought “USB3 eMMC Reader” with GL3227E and after use this with emmc module I’m dissapointed. It is true - reader can read and write faster , but when I put it to usb slot I have to wait too longer … Dmesg gives me many I/O errors, GL chip is very, very hot and when I try to start my OS ( debain, slackware or WIN7) the boot computer is freeze. I can’t boot any OS from this redaer - moreover when I use cheaper emmc <—>microSD adapter whit the same module everything is correct. The most irritation for me is impossibility to use only main pinout ( GND, VDD, CLK, CMD and DAT0 ) to read in 1 bit mode … Wasted time and money …

Most of such software can also verify burned image, have You done that?
There should be no difference with cheap/slow adapter and fast based on GL3227E, checksums will tell You truth.

Yes I know it. But it is not the point - even whitout module dmesg command gives me lot of errors . maybe firmware should be upgraded … Maybe I had immproper emmc module - but why the device can’t read in one bit mode ? In database genesys logic there is information about that . Maybe this is a question for hardware engineers