Docker can't work with Ubuntu Server

Hi everyone,

My name’s Olarn.

I’m using Ubuntu Server with follow this images (Rockpi4/downloads) then i tried to install Docker follow this solution Install Docker but it still not working right now.

please help me to solve this problem.

Thank You.

Please post some error message or logs.

I got this error.

Job for docker.service failed because the control process exited with error code.
See “systemctl status docker.service” and “journalctl -xe” for details.
invoke-rc.d: initscript docker, action “start” failed.
● docker.service - Docker Application Container Engine
Loaded: loaded (/lib/systemd/system/docker.service; enabled; vendor preset: enabled)
Active: activating (auto-restart) (Result: exit-code) since Tue 2019-04-30 16:34:50 UTC; 32ms ago
Docs: https://docs.docker.com
Process: 3272 ExecStart=/usr/bin/dockerd -H fd:// --containerd=/run/containerd/containerd.sock (code=exited, status=1/FAILURE)
Main PID: 3272 (code=exited, status=1/FAILURE)
dpkg: error processing package docker-ce (–configure):
installed docker-ce package post-installation script subprocess returned error exit status 1
Setting up libperl5.26:arm64 (5.26.1-6ubuntu0.3) …
Setting up libxcb1:arm64 (1.13-2~ubuntu18.04) …
Setting up libx11-6:arm64 (2:1.6.4-3ubuntu0.2) …
Setting up libxmuu1:arm64 (2:1.1.2-2) …
Setting up perl (5.26.1-6ubuntu0.3) …
Setting up libxext6:arm64 (2:1.3.3-1) …
Setting up liberror-perl (0.17025-1) …
Setting up xauth (1:1.0.10-1) …
Setting up git (1:2.17.1-1ubuntu0.4) …
Processing triggers for libc-bin (2.27-3ubuntu1) …
Processing triggers for systemd (237-3ubuntu10.9) …
Errors were encountered while processing:
docker-ce
E: Sub-process /usr/bin/dpkg returned an error code (1)

Hi Olarn,

Try installing the latest kernel from Radxa APT

Thank You setq,

After i “unminimize” then Docker it work.

Thank you very much. :grinning:

Thank you for the resolve for running Docker on Ubuntu Server. When I try to install Compose, I get the following error:

standard_init_linux.go:211: exec user process caused “exec format error”

Has anyone successfully installed “Compose” on the Ubuntu Server?
Thanks

Install Docker under ubuntu