Debian 下火狐(esr)用 apt 安装好了,但不能运行


#1

我刚敲完这个标题,右边就提示如下内容:

Your topic is similar to…

  • Debian as arm64
    Feb 18 - One can only download Debian as armhf on your website where all libs and tools are 32-bit. Could you please also upload an arm64 image with full 64-bit support, as described in your manual [2]? [1]…
    (Debian as arm64)

我想,我遇到的问题可能也与 armhf、arm64 有关,请尽快解决。

我下载的 debian 镜像,就是官网提供的镜像。我用 128G 的闪迪 TF 卡制作了启动盘,插在 Pi4B 上就能启动,顺利进入 debian。我能用 chrome 浏览器上网,但我需要 firefox,因为好多网站都只支持 firefox,不支持 chrome。比如,淘宝阿里旺旺的网页版(与客服交流),就不支持 chrome,只能用火狐。火狐是必备的浏览器,请你们把它默认安装好。

我无法回忆我在执行 firefox 出现了什么错误信息。我用 apt 安装好了 firefox-esr 以后,在 debian 的开始菜单里面就能找到火狐的项目,点击它,跳出一个火狐运行失败的对话框,要提交失败报告。反复执行,也都是同样的情况。

进入命令行,执行 firefox 或 firefox-bin,都不成功,输出了几行错误信息,记不得了。


#2

你好,

如果需要用火狐,可以用这个社区的arm64的固件。

https://github.com/SX-GitHub/Debian-ARM64-RockPi4/releases/tag/4.4.154.c83

具体讨论参考:

New Custom Debian ARM64 Build 4.4.154.c83 is finally here!


Rock pi4 的Debian系统关于中文输入法问题
#3

谢谢,救命的一线希望,会试试。我得再买个tf卡再说。先去学习一下。


#4

标记一下,刷了 arm64 固件,完美。


#5

这个固件写eMMC也是可以的。


#6

谢谢,下次买 emmc 了可以试试。