Creating Comm Object failed! error for SPI flash

Here’s the error after flash at boot time by shortcut the SPI1_CLK to GND:

emjay@emjay-on-lmc ~/rkdeveloptool $ lsusb
Bus 002 Device 008: ID 058f:6366 Alcor Micro Corp. Multi Flash Reader
Bus 002 Device 006: ID 0bda:8812 Realtek Semiconductor Corp. RTL8812AU 802.11a/b/g/n/ac WLAN Adapter
Bus 002 Device 004: ID 1a40:0101 Terminus Technology Inc. Hub
Bus 002 Device 003: ID 1b80:d3a8 Afatech
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 008 Device 003: ID 045e:074b Microsoft Corp.
Bus 008 Device 002: ID 045e:0736 Microsoft Corp. Sidewinder X5 Mouse
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 002: ID 056a:00b2 Wacom Co., Ltd Intuos3 9x12
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 077: ID 2207:330c
Bus 001 Device 002: ID 0409:005a NEC Corp. HighSpeed Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
emjay@emjay-on-lmc ~/rkdeveloptool $ rkdeveloptool ld
DevNo=1 Vid=0x2207,Pid=0x330c,LocationID=104 Maskrom
emjay@emjay-on-lmc ~/rkdeveloptool $ rkdeveloptool db rk3399_loader_spinor_v1.15.114.bin
Creating Comm Object failed!

According to the page

After the start, Remove the cable and disconnect PIN23 and PIN25.

Followed the procedure to the letter half a dozen times, to the same result: “Creating Comm Object failed!”
Even changed usb ports… to no avail…!!error%20spi

Try the following command on your host machine

echo ‘SUBSYSTEM==“usb”, ATTR{idVendor}==“2207”, MODE=“0666”, GROUP=“plugdev”’ | sudo tee /etc/udev/rules.d/51-rockpi.rules

Finally, just remove and reinsert the USB cable.

Same result…

Please refer here "Creating Comm Object failed" error when use rkdeveloptool

No eMMC, it’s for the M.2 NVMe I’m trying to set it up (it is unplugged, of course) … I have the 4B 1.4 board…!!

Try using a usb2.0 port

Tried various USB ports 1.1 and 2.0… Same result… I think the SPI had it, I guess…!!

Please directly connect to the USB3 port of the mother board at the back, not the front panel USB3 port.

This computer has no usb3 ports only 1.1 or 2.0. But I did try with 2.0 mobo usb port at the back… same result…! Even tried with the highspeed hub off, at no avail.

Try using method two:

Method 2 requires a working system on SD or eMMC; None of those worked for me; black screen for both, no access to anything… Tried ARMbian and Manjaro ARM Kde… same result…!! I guess the board is not functional and I’ll just have to live with it… Right…!!

Have you tried looking at the output from the serial port?

This is mostly like a usb/cable signal issue. As the device ID is detected, so it means the board is in maskrom mode. Where did you buy the USB A to A cable?

Thought about the cable of course, and did try two other ones (300mm and 1.5m), working of other devices, to no avail…
Utek Pacific is where I buy all my cables… Thanx for the thought tho…!!

I’m getting the same “Creating Comm Object failed” error when trying to flash a new image to the eMMC. Oddly, the Rock Pi 4 still boots to the current image installed on the eMMC, but I want to overwrite it with another linux image. I’m stuck at this error and it’s not allowing me to continue past the rkdeveloptool db rk3399_loader_v1.12.112.bin command. I should say that, in error, I tried to flash the rk3399pro bin file, however the eMMC wasn’t attached and I soon realised my mistake and downloaded the proper .bin file. Have I bricked my Rock Pi 4? Seeing as I’m still able to boot the Rock Pi 4 into the Manjaro Linux installation currently on the eMMC, is there any way to fix this message from within my current Linux install?

I tried using rkdeveloptool on my Mac OS desktop and it worked fine. Must be an Arch Linux specific problem.

I am getting the same error, must the USBa-to-USBa be a 3.0 specification? Currently have only a USB-2.0 specification male-to-male cable, but also the problem may be the old Linux laptop that I was using which has no USB-3.0 port and only 2.0 ports. Please advise…

Hiya Ricklar,
I tried it the other way round, USB3, then USB2 on 3 different cable makes now, at no avail… It is slowly becoming annoying, to say the least…!