CM3 V1.3 + WaveShare CM4-IO-BASE-A won't boot

CM3 V1.3 20220326
WaveShare CM4-IO-BASE-A
Ubuntu Server (https://github.com/radxa-build/radxa-cm3-io/releases/download/main-79d0ef98/radxa-cm3-io-ubuntu-focal-server-arm64-20220501-0202-gpt.img.xz) on sdcard, multiple sdcard tried, currently Samsung Pro Plus 128GB

powered with 5V, boot switch ON or OFF, PWR led always on, ACT led always on


Do you have serial console? What power adapter are you using? Make sure the CM3 is mounted on the IO board properly. I see no led on the CM3 is on. Check the power or mount first.

Thanks for reply.
The LED on CM3 never light.
I have serial console and have expected output with RPI CM4 board on the same WaveShare CM4-IO-BASE-A and the same power supply. But with Radxa CM3 on this board, I don’t have any output use baudrate 1500000 ( Rock3/dev/serial-console - Radxa Wiki ). I can feel little heat on SoC and RAM when connect to power.
Maybe I have a broken CM3 ?

What power adapter are you using? Can you try power from PC USB port?

tried various of power adapter like Anker, ZMI and UGreen, also power from PC USB.
all no luck.

Also, my CM3 board has onboard eMMC, I never write to it after I got the board (means eMMC keep the content from factory, and I don’t know what’s in it), will it prevent boot ?

@bh4ehn

do you have other IO board? The waveshare cm4-io-base-A doesn’t export the USB OTG, so you can not flash image with it.

We can reproduce this here, some power adapters just don’t boot. Our hw engineer analyzed this, his conclusion is the peak voltage is too high for some power adapters that prevents the self boot circuit to boot.

Can you try the following, trigger the global_en to boot(shortcut global_en to ground for less than 1s and release):

really thanks for reply!
Before all, I have to ask, is it necessary to flash one official image to eMMC before I use sdcard to boot?
Or I can boot this board using image on sdcard from a brand new board?

The method above shortcut GL-EN don’t work.
Let me describe the situation in detail. I tried this just before I post. (I can only upload 4 images now)

I have a CM3 board without flash any image into eMMC.
Then I flash “radxa-cm3-io-ubuntu-focal-server-arm64-20220501-0202-gpt.img” (2,000,000,000 bytes) into Samsung PRO Plus microSD card 128GB


this WaveShare CM4-IO-Base-A board works very fine with RPI CM4

but with Radxa CM3 board on with sdcard plugged in, it won’t boot and no serial output.

dim PWR and ACT light always on, also dim light on RJ45 port, no light on CM3 board

I also try CM3 on a working DFR0767 (a dual RJ45 board for RPI CM4), exactly same as above, dim ACT and PWR led and dim light on RJ45 port

Tried a lot power suppliers, like
ZMI HA612
ZMI HA716
Anker A2632
Anker A2718
UGreen CD226 all four port
and a non brand 5V 4A power supplier I used to power Jetson Nano
All these power supply works well on RPI 4B, FriendlyElec R2s/R4s, Rock PI 4B and CM4 on WaveShare CM4-IO-Base-A and DFR0767.

After all these, currently I prefer a got a broken CM3 board