Buildroot for the rock 3 a

I have a successful and super simple Linux OS for buildroot working.

It is part of the buildroot.rockchip external repo :

To make it work, follow the readme or do the following (make sure you have the dependencies setup from the readme first) :

Clone buildroot and the rockchip external dir

git clone git:// buildroot
git clone buildroot.rockchip.ext
git checkout 73248c03fd04eddad78fea5096cd98b2a2d43e81 # note check the readme to make sure this is still correct.


source buildroot.rockchip.ext/ yourPath/buildroot


make rkbin


The command to write is output at the end of the make process


Uboot commands are still manual at this point. Cut and paste the contents of boot.cmd into console when uboot comes up to get linux to boot. See here :


ssh rock3a.local


I’ll give it a try for sure! :slight_smile:

But I met a bug.When I run “make " ,the log prints " buildroot/output/build/.rkdevice-0fe366cf14a6d5d552a5bddbc7b8ff58260ae6e6-br1.tar.gz.ZAWY56/output’ '” 404 not found. I visit the ,but I can find nothing about rkdevice.So I come here for your help.
Thanks again!

Thanks for pointing this out.

I have updated the :

For the Rock 3a, please make sure you checkout the correct buildroot version before building. This will fix that download issue you were having.


Hi! thank you for your buildroot repo. I tried with a recent version of buildroot. The creator has introduced the package rockchip-mali. With some patches on this package (changed the libmali repo with Radxa repo and the install procedure) I sucessfully built an image with qt5 on EGLFS. If you like it we can make a package on your repo dedicated to Radxa board with rk3568. (1.9 KB)

1 Like

Very nice - good to hear it works for you.
You may be interested in patching buildroot for those changes ? Those patches look like they apply to buildroot - right ?

Hi, about the rockchip-mali patch, I just created an alternative package named radxa-mali, that fetches from radxa libmali repo. But require an additional patch to qt5-base package. I don’t know why on the rockchip-linux GitHub page lot of repositories were deleted. In the next week, I’ll try to create a similar package for radxa’s mpp and rknpu2. (172 Bytes)

1 Like

Hello, i’m trying to make buildroot using your instruction, but have problem, i have uploaded screenshots, where can i get sources from that deleted repo?

Hi, you can try to patch the mk file by changing the repo URL

Thank you, but i have next error, i think rockchip deleted some repos.

I noticed this effects the original buidroot.rockchip repo :
Specifically the script which calles rktools/mkimage :

That will have to be updated if a suitable mkimage is found for all platforms. I wonder if rockchip have a suitable mkimage somewhere else ?

Changed to
RKTOOLS_VERSION = 99fbae9d39bea69edbbb12937d49b7d6c8a9c04d
and everything is ok. Thank you!

Hello, i’m trying to add your patch, but i’m getting error (i attached pictures)

Hi, if you are using radxa kernel you don’t need mali-driver, because is already present in the kernel, just remove the dependency between rockchip-mali and mali-driver.

Thank you! My mistake.

Trying to add qt but getting errors, rockchip-mali is enabled, libgbm and eglfs selected.

Hi, have you tried leaving empty the default graphical platform?

Yes, first attempt was with empty platform. I’ll try “make clean all”.

Well, make clean all didn’t help.

> pkg-config error with 'cairo-ft': Could not generate cargs for cairo-ft:
> Package glesv2 was not found in the pkg-config search path.

Same with harfbuzz.
Can you share your .config file, if it’s ok of course. I’m not shure whats wrong with my config.