Archlinux on Rock5b

Well this cable was provided with the monitor (a cheap chinese one so probably not the best). It is working correctly with my macbook. If you manage to get it working with a 10GBs may have a look then.
Unfortunately for the power boot loop, it is the PD issue these boards have… which still remains unfixed.
I think I’ve seen other complaining about audio with HDMI, I would think it is software.

Now for the kernel git version, I managed to boot from it, unfortunately, wayland is no longer working.
I was only able to boot X11.
I need to investigate. I see a some driver or kernel files missing when I run gnome-shell --wayland command.

no it is just part of the glmark2. I cannot run glmark2-es-wayland anymore as I can’t boot wayland session for now.

The scores you are getting are quite surprising. By bin do you mean the blob (and not mesa panfork)?.
If using panfork did you enable to gofaster trick?
After installing new kernel I’m still getting poor score on classic glmark2. With this custom kernel + panfork, we should manage to get score above 3000 as some reported.

EDIT: not sure what happened, just rebooted and now gnome on wayland working again. :thinking:

Redid some benchmarks under wayland, still getting less than 700 in normal panfork, but good news when enabling env var PAN_MESA_DEBUG=gofaster now getting 1500
Still not getting the same score as others managed to achieve, but much better results than stock version.

By the bin, I mean the kernel bin file. Yes I’m running wayland with mesa panfork and the go faster trick. Add: PAN_MESA_DEBUG=gofaster
to the /etc/environment file and reboot. I got this from Reborn OS, I think it works.
Here is my inxi:

Kernel: 5.10.110-1072985-5ed081f51946-3ed94d7-radxa-rkbsp arch: aarch64
bits: 64 compiler: gcc v: 12.1.0 Desktop: GNOME v: 43.2 tk: GTK v: 3.24.36
wm: gnome-shell dm: GDM Distro: Arch Linux ARM
Type: ARM System: Radxa ROCK 5B details: N/A serial:
Info: 3x 4-core model: N/A variant-1: cortex-a55 variant-2: cortex-a76
bits: 64 type: MCP AMP arch: ARMv8 rev: 0 cache: L1: 3x 256 KiB (768 KiB)
L2: 3x 512 KiB (1.5 MiB) L3: 3x 3 MiB (9 MiB)
Speed (MHz): avg: 660 high: 816 min/max: 408/1800:2400 cores: 1: 816
2: 816 3: 816 4: 816 5: 600 6: 600 7: 408 8: 408 bogomips: N/A
Features: Use -f option to see features
Device-1: display-subsystem driver: rockchip_drm v: N/A bus-ID: N/A
chip-ID: rockchip:display-subsystem
Device-2: mali-bifrost driver: mali v: N/A bus-ID: N/A
chip-ID: arm:fb000000
Device-3: rk3588-dw-hdmi driver: dwhdmi_rockchip v: N/A bus-ID: N/A
chip-ID: rockchip:fde80000
Device-4: rk3588-dw-hdmi driver: dwhdmi_rockchip v: N/A bus-ID: N/A
chip-ID: rockchip:fdea0000
Display: wayland server: v: with: Xwayland v: 22.1.7
compositor: gnome-shell driver: N/A display-ID: 0
Monitor-1: DP-1 model: Gigabyte M32U res: 3840x2160 dpi: 140
diag: 800mm (31.5")
API: EGL/GBM Message: No known Wayland EGL/GBM data sources.
Device-1: hdmi driver: rk_hdmi_sound bus-ID: N/A chip-ID: rockchip:dp0-sound
Device-2: simple-audio-card driver: asoc_simple_card bus-ID: N/A
chip-ID: simple-audio-card:es8316-sound
Device-3: rk3588-dw-hdmi driver: dwhdmi_rockchip bus-ID: N/A
chip-ID: rockchip:fde80000
Device-4: rk3588-dw-hdmi driver: dwhdmi_rockchip bus-ID: N/A
chip-ID: rockchip:fdea0000
Device-5: hdmi driver: rk_hdmi_sound bus-ID: N/A
chip-ID: rockchip:hdmi0-sound
Device-6: hdmi driver: rk_hdmi_sound bus-ID: N/A
chip-ID: rockchip:hdmi1-sound
Device-7: simple-audio-card driver: asoc_simple_card bus-ID: N/A
chip-ID: simple-audio-card:hdmiin-sound
Sound API: ALSA v: k5.10.110-1072985-5ed081f51946-3ed94d7-radxa-rkbsp
running: yes
Sound Server-1: JACK v: 1.9.21 running: no
Sound Server-2: PulseAudio v: 16.1 running: yes
Sound Server-3: PipeWire v: 0.3.64 running: yes
Device-1: Realtek RTL8125 2.5GbE driver: r8125 v: 9.009.00-NAPI-RSS
port: 200000 bus-ID: 0004:41:00.0 chip-ID: 10ec:8125
IF: enP4p65s0 state: up speed: 1000 Mbps duplex: full mac:
Device-2: wlan-platdata driver: wlan_platdata v: N/A bus-ID: N/A
chip-ID: wlan-platdata:wireless-wlan
Local Storage: total: 465.76 GiB used: 19.72 GiB (4.2%)
ID-1: /dev/nvme0n1 vendor: Smart Modular Tech. model: SHGP31-500GM-2
size: 465.76 GiB speed: 31.6 Gb/s lanes: 4 serial:
ID-1: / size: 458.05 GiB used: 19.63 GiB (4.3%) fs: ext4 dev: /dev/nvme0n1p2
ID-2: /boot size: 511 MiB used: 87.9 MiB (17.2%) fs: vfat
dev: /dev/nvme0n1p1
ID-1: swap-1 type: zram size: 7.51 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
System Temperatures: cpu: 49.0 C mobo: N/A
Fan Speeds (RPM): N/A
Processes: 281 Uptime: 1h 12m Memory: 7.51 GiB used: 2.5 GiB (33.3%)
Init: systemd v: 252 default: graphical Compilers: gcc: 12.1.0 clang: 15.0.7
Packages: pm: pacman pkgs: 818 Shell: Bash v: 5.1.16 running-in: kgx

Ok thanks for details, then we get about same scores now. And if you say this is the same as Reborn, then I guess we are ok with that for now. Will check on discord to know why some got better scores.

Next step will be try running some X86 games on it :nerd_face:

have you looked to Typec connected to monitor no sound

Thanks!! The solution in that link worked. Now I have power, video and sound through usb-c.


@Joperfi @Etienne

I am aware of wayland issues. I know the reason but i dont know the root cause. we need someone smarter for the root cause and fix.

The reason is, i am compiling mesa not as GL vendor. There is an option to wrap the GL libraries from different vendors called GL vendor users can switch different vendors easily. Thats provided with /usr/lib/libGLX. Since the way we use mesa-panfork does not have such interface Wayland is going banana time to time.

I did not specificly enable GLvendor because @icecream95 had already mentioned issues with it, and i have several times obrserved the same. However i noticed that lacking GLVendor causes bigger issues now i have added a patch to enable it. So if you get the latest package mesa-panfork-git it should run fine.

But again unfortunately this is a breaking change meaning that first you must remove the old installed mesa-panfork-git . Warning this will also remove all mesa and stuff that depends on it including gnome.

so you first need to sudo pacman -Rcns mesa-panfort-git and then makepkg and and install it again.

BONUS: i have also enabled gallium-9 for DX9 things.

Note: expect some issues with binaries requires GLVendor. This is valid for all osses not arch to my guesstimation.

1 Like

Also -bin kernel files do not have the GOFASTER patches. They are vanilla from radxa.

Thks for clarification. I guess I got rid of my wayland issues by reinstalling mesa-panfork.
Doing some testing, gnome on wayland feels very smooth.

Also trying to get box86 compiled on arch. There is a package on AUR but it seems it isn’t compatible (only supports armv7h). Would be nice to have that package updated for using on rock5b straight away.

thank you for pointing out how to gofaster.
After reinstalling mesa-panfork-git
glmark2 Score: 1787
was possible in my case.
I have seen various random freezes with gofaster and normal gnome desktop use, therefore i turn it off again.

I’ve used Arch for some time now with good results.

Been using with my 49” Samsung monitor that has PD built in so power in and display output from my rock has been through USB-c.
Usb-c correctly identify the monitor as 49” Samsung but unable to get higher than 3840x2160 on the usb-c.

So connected HDMI cable from rock to monitor and radxa psu.

Both HDMI1&2 is stone dead. No output.
Monitor do not even recognize a hdmi device is connected.

I’m out of ideas how to solve it.

When connecting rock with both USB-c and hdmi I can see the Samsung monitor in gnome gui as ”unidentified 49”” and limited to 1080 res.

I heard you need to add some overlays to enable 8k output. There are some stuff about it in the forums. You can edit your extlinux.conf to activate overlays

Has anyone here tried to compile any of the examples in It doesn’t work for me, I get error messages from the linker program. I’m wondering if the code in rknpu2 can even be run on Arch ARM.

Those build scripts are very broken and they matches the target by the compiler file name because Rockchip Developers assumes nobody builds these source code on arm64 machines natively and always using cross-compiling on x86 machines.

If you try to compile it natively on aarch64 machines, your compiler mostly will not contain the prefix “aarch64”, this confuses the cmake setup and it ends up with trying to link an armhf library to an aarch64 binary, hence the error.

To fix it, a brutal way is to search and replace all the “armhf” with “aarch64” in the CMakeLists.txt in each examples.

Thanks, I’ll give that a try.

The examples compile now. Now I just need to figure out how to convert other models to the .rknn format and get rknpu2 to run them.

Hi, I installed RebornOS, which is arch linux based.
Installed ffmpeg4.4-mpp with: yay -S ffmpeg4.4-mpp, but I’m unable to use it to play HEVC files.
In terminal: ffplay4 sample.2160p.hevc.mkv starts playing, but I didn’t see any picture, and the console gives me:
[hevc_rkmpp @ 0x7f78279150] Unable to convert …
And this repeates.

Anyone can help?

thats weird, can you provide log output of:

ffplay4 -loglevel repeat+level+debug -i videofile

Attached, it is slightly big when you unzip it. (15.0 KB)