Arch based RebornOS reviewed on Rock5b

I solved the problem with booting (doesn’t boot from ssd nvme only with SD card), it has to be changed in extlinux.conf from nvme: append root=PARTUUID= with append root=UUID=… now it boots without SD card. SPI must be enabled by writing the file rock-5b-spi-image-g49da44e116d.img
Regarding touchpad support: I discovered the problem with the Apple trackpad, it is not activated when compiling: # CONFIG_HID_MAGICMOUSE is not set and must be activated as a module: CONFIG_HID_fMAGICMOUSE=m
Can it be activated in the kernel?

Tried the new image with Gnome + wayland.
GPU is working! Used Chromium for webgl fishtank and misc. other tests. GPU in Chromium taskmanger confirms.
Youtube plays all videos with no dropped frames. Even 2160p 4K as well but then heavy on the CPU.
Nice work!

New image to SDcard
Install Online
Added Wayland under Advanced.

Correction on GPU: GPU is used but supplemented by CPU. I see ~ 20% cpu on 1080P HD fullscreen.

But the thing is it’s super snappy and does not drop frames. Way better thatn RPI4 overclocked which has “full” gpu support.


glad to see we finally get more perfs than a RPi4 :joy:
I wonder what it will be with full GPU support

1 Like

Is possible to add option to Calamares installer to allow RebornOS (booted from SDCard) to install directly to nvme?

Yes but that requires everyone to have an nvme/emmc

1 Like

Reinstalled the latest image and the video playback in chromium worked once (!), but there were still dropped frames. Even after reboot it refused to play a video neither in chromium nor in firefox.

I installed mali-g610-firmware on R5b via RebornOS software install tool (welcome screen/utilities) it applied gpu acceleration to chromium and other applications. I rebooted and it worked great.
In chromium - aquarium - 1000 fish 60fps, 5000 fish 32 fps.
YouTube video playback 4k 30fps - zero dropped frames
In Firefox - webglsamples crashed everytime.
YouTube playback - same as chromium, with one small exception… dropped 37 frames in first 400 frames then zero in next 3000 frames.

Thanks for the update. Again, I reinstalled Reborn OS and as you suggested, I installed the Mali G610 wayland package. After the installation finished, I performed the required reboot. After reboot the system got stuck with a black screen and a blinking cursor.
At this point, I am considering a hardware fault to cause these problems and therefore, I think it*s best to put the rock 5b aside for some time.

Same result as with my pixel4a (S730G - Adreno 618) although Mali-G610 is supposed to be more than 3x times more powerfull.
Still not at perf level we can expect from that GPU
Would be worth checking on android how much G610 gets in comparision

Yeah, try native Chrome on android to get the picture of the real capabilities of the GPU. The FPS don’t fall below 60 even with 10000 fish.
(I remembered it wrong, the FPS with 10k is 28, with 5k it’s about 60)

1 Like

Good to know. Makes sense since android is using vendor gpu drivers supposed to fully exploit GPU perfs.

Has anybody had success in getting AetherSX2 running with Vulkan?

I selected Vulkan under graphics then get an error “Failed to create host display device context” when trying to start a ROM. I’ve tried all the other graphics options too. I saw a few additional Vulkan packages in the software store but haven’t found anything that is helping.

As far as I know, Panfork doesn’t support Vulkan at this point.

The ETA prime youtuber did get Vulkan to run on AetherSX2. There’s probably some other config steps he performed that we’re missing.

Have you tried running with the Mainline Ambian 6.xx kernel?

Can someone please go into etc/environment file and provide the “go faster” setting I know is there. Dumb error on my part, I overwrote it. Thanks

Do you know if any extra kernel patches were added for the GPU, display?
Seems RebornOS supports 4k@120hz resolution while other Linux OS’s and Android gives a black screen or no signal with 4k@120hz.

Where can I find the PKGBUILD of this package called linux-rockchip-rk3588 ?