Arch based RebornOS reviewed on Rock5b

I’m trying to use gnome.

How much RAM do you have?

How did you put it on NVME

just write the image to the nvme

Where do I have the writing option, during installation or does the installation image have to be written?

Put the nvme ssd in ur pc then write to it if u dont have nvme on ur pc install rebornos on an sdcard first then use rpi imager to write the image to the ssd

Ok thanks, I will try option 2.
I installed but I can’t enter from gdm3 neither in gnome nor in gnome wayland, the above error appears.

it looks like the GPU isn’t being used and that’s what’s causing the problem. Kde can cope withou the GPU but gnome can’t. Not sure why it’s not working as the firmware is present as is the mesa-panfork-git

I am facing the same problem (“Oh no! Something has gone wrong”). So what did ETA Prime to get the GPU working? Luckily he didn’t show us in his video, which would have ruin our experience on RebornOS on the Rock 5 B.

Some update broke it :frowning: it was working before

Ahh I see :neutral_face:

I found a fix I’m pushing asap

Thank you for your work. I am really looking forward to test RebornOS on the Rock 5B. I would like to contribute, but I am quite new to Linux and SBCs though.

You can contribute by testing. :slight_smile: Consider joining our discord server.

Latest image fixed it @blondu (

1 Like

Thanks! It works, now I’m testing firefox wayland…
I have another problem with the touchpad, it doesn’t work, click with two fingers on the right button.

No idea but you can check in the settings app

by bsp kernel do you mean the ported android kernel radxa uses?

I tested the new version.

I downloaded the new image and ran the online installer. I went with the gnome desktop and added wayland under Backend System/Display/Wayland.

Unfortunately I was not able to run any video in Firefox or Chromium under wayland. With Xorg video playback worked in both browoser, but with frame drops. Aside from that, the OS felt very smooth.

kernel by radxa