Android 11: Multitouch not rotating

I’m trying to use this as a kitchen display panel. I need portrait layout so I’ve tried every way to make the screen rotate 90 degrees. Rotating the screen works fine, but the multi-touch driver does not rotate the inputs. The touch x and y axis continue to function as if the display was still at 0 degrees.

This is the uevent data for the touch interface:
PRODUCT=3/222a/1/110
NAME=“ILITEK ILITEK-TP”
PHYS=“usb-xhci-hcd.1.auto-1/input0”
UNIQ=""
PROP=2
EV=1b
KEY=400 0 0 0 0 0
ABS=260800000000003
MSC=20
MODALIAS=input:b0003v222Ap0001e0110-e0,1,3,4,k14A,ra0,1,2F,35,36,39,m5,lsfw

Swap x with y and you are done! (When the screen is rotated)

Its likely the driver for the mouse so if you do a google for roate touch input you will prob find ‘set prop’ command

I have no way to do that.

I already spent all weekend doing that. There’s no setprop for rotating that that I could find.
:frowning:

Isn’t it any app, code, script? If you have no access to interior of your app you will not be able to make it work!

No, not an app. I want the OS to be rotated. The same thing that would happen when you rotate a phone or tablet that has accelerometer and geomagnetic field sensors.

Its in the link I sent ?

Thanks for the link, @stuartiannaylor, but unfortunately Android doesn’t work the same as Ubuntu. It doesn’t have Xorg (or wayland, for that matter) and thus no xinput (or xrandr, etc).

Oh Android prob it will do it automatic if you call the android setting and way of doing it for screen rotation.
I would do a google on screen rotation and make sure you have picked the best method.

Been there, done that, tried them all and tried several apps that are intended for that purpose (and are tested to work on a phone and tablet). :frowning:

Each of the methods attempted also do work on rooted phone, so I know they should work, they’re just not. Maybe this build of Android has a bad driver.

Using radxa-android11-20211115_1851

Dunno Android aint my thing niether are touchscreens as struggled with similar before where it seemed better to have a DTB with the correct orientation.
I can never work out the settings and timings for that and can not help.

Pi does it that way and all the screen settings are in dtbs just config.txt sets the right one.
All I can offer is empathy apols.

1 Like

Thanks for trying. It’s always nice to feel like you’re not shouting into the void.