4C_plus no running OS?

I bought a rock pi 4C+ with 4GB RAM expansion and 256GB M.2 and am pretty disappointed. I’ve been trying to install OS for hours but the PI just won’t boot correctly.
In fact, the PI only boots when I remove the M.2. But not with every OS (source https://wiki.radxa.com/Rockpi4/downloads) it looks like.
Ubuntu Server can be used, but it’s not what I want.
Debian Desktop won’t boot and Dietpi freezes
I haven’t tried Android.

Hi, @Andy_Luth

What 2230 SSD are you using? Can you take a picture of the SSD?

Make sure you download the right image for 4C+.

Third party image may not support 4C+ yet.

The os is debian desktop for 4c+ from the wiki. here with OS on eMMC.

Support is done. The ROCKPI 4C+ has just died. Just like that during operation.
25 hours…

Hi,
I have exactly the same setup and can’t get it working either.
Can anyone share information on how to setup this configuration ?
and please share the latest image,
currently I’m using rockpi-4cplus-ubuntu-focal-server-arm64-20220501-0307-gpt.img.gz

I ordered 10 of these setups so I hope to get it working!

It does recognise the NVME but does not boot from it

36|666x454

You can click on this link to download the latest image and try again:

rockpi-4cplus-ubuntu-focal-server-arm64-20220520-1242-gpt.img.xz

I’ve just tried, I have the same problem,
do I just need to plugin the NVME and boot or do I need to do more ?

ROCK Pi 4C Plus can not direct boot from SSD, you need to plug the SD card for bootloader and kernel, rootfs can be put on the SSD. To do that,

  1. boot from SD card with SSD attached, as you do now

  2. write the image rockpi-4cplus-ubuntu-focal-server-arm64-20220520-1242-gpt.img.xz to SSD with:

    xzcat rockpi-4cplus-ubuntu-focal-server-arm64-20220520-1242-gpt.img.xz | dd of=/dev/nvme0n1

  3. use parted to delete the rootfs partition in SD card.

    parted /dev/mmcblk0

  4. reboot, you will boot from SSD now

2 Likes

Yes this works !
thank you,
is there no way to have only the nvme installed ?
so NO SDcard and NO eMMC ?

Well, ROCK Pi 4C doesn’t have SPI flash on board, you can solder one:

https://wiki.radxa.com/Rockpi4/hardware/spi_flash

Then you can put the bootloader only in the SPI flash.

Could you share what is the exact Make/Model of your 2230 NVME drive? I have a KIOXIA KBG40ZNS256G, Andy_Luth has a KBG4AZNS256G but I am not sure if he ever got it to detect. My problem is no matter what I do, SPI programmed even or bypassed with pins, my rock pi 4c plus does not boot to anything SD or NVME with etcher image when I have the NVME plugged in. If I unplug the NVME I can then boot fine to SD.

Can I ask you where did you purchase your 2230 NVME drive? I have looked everywhere for KBG4AZNS256G and all I could find was the one I bought KBG40ZNS256G, which doesn’t seem to allow me to boot my 4c plus when it’s plugged in.

Hi I bought my NVME at laptopcentrale-dot-nl/product/dell-oem-toshiba-bg4-series/
it is a KBG40ZNS256G
I did not solder a SPI flash, so I’m still using the boot loader on the SD card and I used the method of jack

Hello im having the same problem here, when i have the SSD connected the rock pi 4c + wont boot, I have to turn it off and take it out and then it boots. Did anyone manage to solve the issue or found out why it happens? Im just trying to have SSD working as a storage unit in the rock pi not booting.

I have a pic of the SSD I got.

What is your power adapter? It’s mostly like the power is not enough.

im using a 10w charger from an old ipad. Im in Europe so voltage is about 240