Zero fails to boot

I bought a zero to use for a 3d printer, but I can’t get it to boot at all or show up as a usb device.

  1. plug in with button pressed
  2. flash radxa-zero-erase-emmc.bin
  3. replug with button pressed
  4. flash z-udisk-loader.bin
  5. wait for usb device (never shows up)
  6. replug with no button pressed and wait (never shows up)
  7. replug without button pressed and wait (never shows up)

in all cases it still shows up as Amlogic, Inc. GX-CHIP

attempting to flash an OS to the emmc always fails, usually at about 3%.
attempting to boot with any image on sdcard (tried factory, android, raspbian, and fluiddpi) seems to do nothing (tried with blank emmc and with uboot on emmc.)

I’ve never gotten any output at all over hdmi.

Printer’s screen never lit up with fluidd image, so it never booted since if it had it would have initialized the controller in the printer which manages the screen.

You could try to see if there is any interesting output on the serial console: https://wiki.radxa.com/Zero/dev/serial-console

I got Radxa Zero, my first ever SBC, delivered yesterday. I prepared and plugged in a SD, … and couldn’t get anything to show up on HDMI either. Just the green power led and that was it.

But once I connected to the serial console, I could see the bootloader and kernel messages, and could confirm it was in fact alive :slight_smile:

got a usb to serial adapter, and this is all I get on the output when I power on the zero:

^+k▒6%▒▒[▒▒▒▒▒▒-{K