Zero D4E64H unable to detect eMMC on PC and more!

My Radxa Zero 4GB 64GB I have here infront of me is having issues being detected by balenaEtcher as a writable storage device. I’ve followed the guides and used RZ_USB_Boot_Helper + radxa-zero-erase-emmc.bin to erase the onboard eMMC and it does get detected by windows as a GX-CHIP in device manager under libusb-win32 devices. But in balenaEtcher is is not showing up when I look for the target device. I’m trying to get radxa-zero-debian-buster-xfce4-arm64-220220616-0314-mbr.img to be written to the onboard eMMC, rather than using an SD card. I also need to test the WiFi as this device was reporting WiFi connectivity problems through Ubuntu from booting off a SD card, firstly the WiFi connection wasn’t showing up in the GUI and had to be manually connected using the text mode client, there after the connection was dropping out, but that could be due to a network issue on my end, not entirely sure.

On a side note, the device doesn’t boot up in any form when powered separately from a USB C cable with an adequate Power Adapter, no output from HDMI. The Green LED doesn’t turn on when powered by non PC connection methods, and when plugged into my PC its a steady green LED that turns on.

Any help or added tips / info on what my next steps should be would be very appreciated!

You should load radxa-zero-erase-emmc.bin when the device is detected as GX-CHIP, then after a few seconds it should turn into a USB storage device by itself for Etcher.

Please try with the latest image.

I tried this and no result with it booting from debian(new version) on eMMC, separately the green LED turns on whenever plugged in now, after flashing the gx-chip with the previously said debian(happy that worked)


I had a an issue booting with peripherals connnected like HDMI and wifi dongle using a usb c to usb c cable conected to a 5v/3amp usb c charger. As soon as I changed to a usb c to usb a cable and a usb A 5v/3a charger all was good.

Please try booting without HDMI connected.

thank you for the reply, unfortunately this doesn’t seem to change the outcome. I appreciate your response :smiley:

This unfortunately doesn’t seem to change the outcome. The green light turns on, and that’s it. Doesn’t boot into anything.

On top of this, the device is still having such a hard time being picked up by etcher. I was able to get it to show up once, after multiple failed attempts(not in rapid succession) and I was able to write to it, but not boot from it. And now when trying to assure that the device works with your added information on what steps should be taken, it is failing to be picked up. Following the correct directions and everything as I did before. thank you for your reply and further continued help on this matter.

Please attach a serial console and attach the output.

I do not have a serial console.