Zero cannot connect to wifi

Hi, I cannot connect to wifi using radxa zero. there is no wifi device detected by the system. It constantly DOES NOT work only worked less than five times. I wonder if it is the hardware problem.
The OS i am using is the ubuntu server version from radxa website. I also tried DietPi, which never detect wifi device at all.

Hello. What is your hardware version?

It is Radxa Zero V1.51. THX

I changed OS to manjaro, wifi works perfectly. it is so sad the official ubuntu OS does not work with the wifi. I really wish to use the radxa official OS since I cannot compile mraa on other OSs, including DietPi and Manjaro, they all gave same error as :

/usr/bin/ld: CMakeFiles/mraa.dir/version.c.o:(.data.rel.local+0x0): multiple definition of `gVERSION’; CMakeFiles/mraa.dir/mraa.c.o:(.bss+0x0): first defined here

/usr/bin/ld: CMakeFiles/mraa.dir/version.c.o:(.data.rel.local+0x8): multiple definition of `gVERSION_SHORT’; CMakeFiles/mraa.dir/mraa.c.o:(.bss+0x8): first defined here

collect2: error: ld returned 1 exit status

make[2]: *** [src/CMakeFiles/mraa.dir/build.make:562: src/] Error 1

make[1]: *** [CMakeFiles/Makefile2:319: src/CMakeFiles/mraa.dir/all] Error 2

make: *** [Makefile:146: all] Error 2

I need mraa, but wifi is more important…

Have you tried the AUR?
git clone cd into dir and

makepkg -si

The Manjaro guys might have an idea as its pretty important @spikerguy

1 Like

Thank you. This AUR only works on x86_64 or i686, aarch64 is not supported. Since radxa zero is not officially supported by eclipse, even on Radxa official OSs I can only compile Radxa’s mraa successfully. Hopefully they can fix athe wifi problem on thier own OS soon.

The pkgbld prob has only declared x86_64 but doubt it will work anyway as each board has its separate definition with the arm boards being in

Prob your error is due to not knowing what board it is and not having a specific definition you can try through khadas examples as likely with some searching you will find somewhere around cat /sys/kernel/debug/pinctrl/pinctrl@4b0/pins

Thank you. Radxa’s mraa provides definitions of their boards but it has multiple definition of const gVERSION as I mentioned above. I will try to figure it out.

I had a google
Says they fixed it by “When disabling the tests, it works”.

So at a guess turn to ‘OFF’ and try again. PS clicked on the wrong line but the tests one.

Glad to hear that WiFi is working properly. I will try Manjaro.

Well, thank you for the effort. I really appreciate it. I turned off the test but it still have multiple definition. I also tried to use the solution mentioned in the first link “comment version.h and coping lines to mraa.c”, still no good luck. I just gave it up since how to enable GPIO is also unknown to me( I asked in the forum so far got no feedback).

I would go on the manjaro forum and ask as thinking it is likely a common a common build problem that they know about.
Things are sort of broken on a SBC without something like mraa

I’m there with you - I’ve tried 3 different Manjaro releases (even one from Manjaro site for Radxa Zero) and I can’t get the wifi working at all. Can someone maybe tell us what the secret is? I go into nmtui, add a new connection, fill in SSID, device as wlan0, security as WPA & WPA2 Personal, put in my password, and OK. I go to Activate and there is no profile to activate. Is there another way of doing this? I think I even tried the wpa_supplicant route and still no luck.

Last image tried: Manjaro-ARM-xfce-radxa-zero-20220207.img

Don’t know if it help but I should first activate Wifi on my debian zero board to work properly :
nmcli r wifi on
nmcli dev wifi

See here :

for your mraa problem : you can also work with gpio by modifying /sys/class/gpio/… files

I followed the steps listed in the link. On the last command to connect - I got the this:

Error: No Wi-Fi device found.

That’s the frustrating part of all of this - you get something to work under one distro, but it doesn’t work under a different distro (and vice versa).

did you have a wifi error specified on boot when you tape “dmesg”
you shoould see something related with brcmfmac (Broadcom brcmfmac driver)

a service is probably missing, maybe try :
systemctl enable NetworkManager
systemctl start NetworkManager

You can also use a usb rj45 dongle in last resort

I think the default distro hit some politics problems as your seeing the fallout from that.
So the manjaro image is playing catchup to that and so is the debos version which originally used an armbian build so yeah things are a bit disjointed but coming back together again.

Same with debian as yeah there are a few versions floating about so use the latest and post which one you used as think we are all a little confused but things seem to be sorting out as does the wiki.

you can compile for aarch64 using -A as it ignored the arch and compiles for host arch.
makepkg -A

I tried AUR version along with radxa source both fails to compile.

 29%] Built target python2-mraa_swig_compilation
[ 30%] Linking C shared library
/usr/bin/ld: CMakeFiles/mraa.dir/version.c.o:(.data.rel.local+0x0): multiple definition of `gVERSION_SHORT'; CMakeFiles/mraa.dir/mraa.c.o:(.bss+0x28): first defined here
/usr/bin/ld: CMakeFiles/mraa.dir/version.c.o:(.data.rel.local+0x8): multiple definition of `gVERSION'; CMakeFiles/mraa.dir/mraa.c.o:(.bss+0x30): first defined here
collect2: error: ld returned 1 exit status
make[2]: *** [src/CMakeFiles/mraa.dir/build.make:466: src/] Error 1
make[1]: *** [CMakeFiles/Makefile2:391: src/CMakeFiles/mraa.dir/all] Error 2
make: *** [Makefile:146: all] Error 2
==> ERROR: A failure occurred in build().

You don’t have to add SSID manually, it should show by default.
Something like this

This have everything needed for the wifi to work unless your wifi is broken or you have not attached the antennae.

Can you share the output of the following?
sudo dmesg | grep brcm
inxi -N

Do you have wifi chip on your board ? Just confused as you don’t have wifi on any distro including official distro from radxa ?

One of my 2 wifi dongles worked. I’m doing a system update to see if that fixes anything. If not the dmesg is huge - clues to narrow it down before I post a gigantic bunch of text).

Also, got errors on the system update.

Error: ap6256 firmware: signature from “Furkan Kardame <>” is unknown trust.

Does also have probs?

Both Mraa & gpiod are sort of needed as default packages for gpio

dmesg | grep wlan0 ?