Zero 3W wifi not connecting

I’m struggling here. First I couldn’t get the keyboard/mouse to work - the USB hub worked fine plugged into my laptop, but not on the Zero, whether power went to the Zero or first to the hub. Using a different hub worked, so not sure why it’s so fussy. The second hub is USB-A, so I’ve also got A->C dongle, C-joiner dongle, C->C cable, then into the Zero, which is a mess but it works.

But now I cannot connect to wifi - it shows me all the APs and lets me put in the password, but spins for a while and asks for the password again. I do not have an external antenna connected, and I don’t know how to select between internal/external, but it thinks the signal strength is fine. I’ve done an “apt upgrade”, and am running “radxa-zero3_debian_bullseye_xfce_b6.img” from microSD.

Any help would be appreciated.

I would check to see if your keyboard mapping is incorrect. Type the password into the command line so that you can read it back. If you keyboard mapping is working properly… I have no idea why you would not be able to connect (I connect just fine with the same OS version).

Yeah I ticked “show password” and it looks ok, but it does give me something to consider, so thanks.

I have the same problem using Debian XCFE as well. Password is correct, but the Zero 3W will not connect to the Wifi. I thought maybe it is a WPA2/3 compatibility issue, so played around with those settings in Router UI but nothing worked. I have a Rock Pi S working fine, no idea Zero 3W is not connection.

I gotta say, it has been a horrible experience dealing with Zero 3W. Hardware is great but without proper software, it is just not very useful.

I managed to make it work, in case someone else also needs it.

I changed band to 2.4GHz and security to WPA/WPA2 and it worked.