Zero 3W doesn't boot and no data in debug mode

I recently bought two Radza Zero 3W from RS with 1GB of RAM and no eMMC. Model number: RS107-D1E0H0W15

I loaded an image of Armbian onto an SD card (256GB Samsung Pro Endurance), and tried to fire it up, but I get no display output, and the keyboard doesn’t light up (backlit keyboard). The green LED between the USB ports lights up, but that’s it.

It came without and GPIO headers, but I soldered on a the pins that are needed for debug console, but didn’t I get no data at all in the console. I am using Putty in Linux (Mint) and a PL2303HXA USB to TTL adapter. Baudrate 1500000, No parity, 8 bits. I have tried both XON/XOFF and None for flow control. Not even getting any random signs or letter. Absolutely nothing.


I have connected the wires from the USB converter to the following ports (pin name on drawing is the pin on the converter).

As troubleshooting steps, I have also tried Ubuntu, Debian, Manjaro and DietPi (images for the Zero Series specifically). I have tried a 32GB Samsung and 16GB Sandisk SD card as well.

Does anyone know what I’m doing wrong? Is there something extra that has to be done on these non-eMMC devices?

Thank you in advance for any help on this :smiley:

Edit: I have the same issue on both of my Zero 3W (bought at the same time).

The first USB-C is for power. 5V 2A

I think if your board(s) have no eMMC it might need a different u-boot version. (or vice-versa). Try to boot with older images.

I feel stupid now. Every single image I tried was for Zero and not Zero 3.

Newest Debian Xfce b6 official image is working (https://github.com/radxa-build/radxa-zero3/releases/tag/b6).