Zero 3e serial console gibberish

so I’m trying to add support for openwrt (see ) and I’m hitting some uboot issues where a console log would be handy.
I’ve set it up according to UART Serial Console | Radxa Docs - tried both on win10 and ubuntu 22.04 but all I get is gibberish on all boot stages - tried both baudrates of 1.5mil and 115200
the console (pl2303 clone) works just fine on another board (rpi cm4)

any hints ?

We have received report of some “PL2303x” based products cannot support 1.5M baud. Please check if you can use some alternative USB TTY cable.

thank you - should have remembered that from the lessons learned working with the other radxa boards.
but I’m getting the same gibberish even with 115200 that’s working with rpi-cm4 or radxa-cm3-io.
Luckily I have some other serial console usb adapters and can try that in the meantime.

You can’t really change the serial console baud. IIRC it is hardcoded in the device tree.

I know but as I’m compiling from source everything at least on this point I can override the baudrate at my own choosing

EDIT - I see now 1.5mil is also in openwrt - I wrongly remembered that it was 115200