Yocto layer for Radxa boards

Hi. I’m maintaining a yocto layer called meta-radxa. Currently it has support for Rockpi-4, RockPi-S and the RockPi-E. Here is the link to meta-radxa if you want to build your own image. I currently don’t have the RockPi-4 and the RockPi-E and hence I’ve not been able to test the current builds. If anyone is up for testing these builds here are the images.

RockPi-4 Thud Builds

RockPi-E Thud Builds

Would really appreciate if someone could send me the console logs of it.

2 Likes

Update:

I’ve updated the boot.cmd and uEnv.txt for RockPi-E in the meta-radxa layer. The board should boot up now. Anyone up for testing please use the link above and do send the debug logs. Serial console should be available on UART-2.

1 Like

A quick update:

There was an issue with the trust.img for RockPi-4 and RockPi-E. That has been fixed and the images have been updated on the above links. I received my RockPi-E(D8W2) sample today and have tried the fixed RockPi-E builds. They work perfectly fine. So you can now build your custom image for the RockPi-E board successfully using the meta-radxa layer.

Hi, @nish

I run system image, https://www.dropbox.com/sh/mt9f47u5mkm7kpz/AADV3EIY3nolImBpigmktMUOa/radxa-console-image-rockpi-4b-rk3399-gpt.img?dl=0 on ROCK Pi 4B. The Ethernet, HDMI, USB and so on are working well. But there is one problem with Wi-Fi connection.

From the boot log, I find that there is not AP6256 firmware in /system/etc/firmware/ directory.

To fix that, you can get the AP6256 firmware from this package, https://github.com/radxa/apt/blob/gh-pages/stretch-testing/pool/main/b/broadcom-wifibt-firmware/broadcom-wifibt-firmware_0.6_all.deb . And add the following three files in /system/etc/firmware directory.

root@rockpi-4b-rk3399:~# ls /system/etc/firmware/
fw_bcm43456c5_ag.bin  fw_bcm43456c5_ag_p2p.bin  nvram_ap6256.txt
1 Like

Hey @Stephen

Thank you for taking time out to test the image for RockPi-4. Yes the firmware for AP6256 was missing. I’ve included the firmware to the new builds and also updated the meta-radxa layer for the same. The wifi for RockPi-4 should work now. If you want to try it out here is the link: https://www.dropbox.com/s/767wgi4ktgbo6rr/radxa-console-image-rockpi-4b-rk3399-gpt.img?dl=0

Just a quick update:

I’ve updated to warrior. Here is the change log from thud to warrior:

  1. RockPi-S Kernel updated to 4.4.143-39-daf243b9655a73ee14568e36cf76ac8a094e68e6
  2. RockPi-S U-Boot updated to 2017.09-c3d3bc84bef5ee95d7199c23e1a34e47ea8f0daf (Supports boot.cmd and uEnv.txt)
  3. RockPi-4 Kernel updated to 4.4.154-95-d2ab1f26e1b33970a6ccda18633a681a7730665e
  4. Firmware file location fixed for RockPi-E
  5. Bluetooth works for RockPi-S, RockPi-E and RockPi-4
  6. Added instructions on how to setup bluetooth for each board
  7. RockPi-S serial console changed from UART-2 to UART-0
  8. Radxa binaries are now taken from the radxa official repository

nish,
thanks for your yocto support. I cloned meta-raxda and build successfully the image for the rock pi S. Nice and easy.

Trying to modify the kernel to include gadget audio support, here my steps:

   bitbake linux-rockpi-s -c menuconfig
   bitbake linux-rockpi-s -c do_compile -f
   bitbake linux-rockpi-s
   bitbake -k radxa-console-image

But still no gadget support.
You have any recommendation how to build a custom kernel?

found the issue, the gadget support needs to be set as ‘Module’. the default config has it set in a ‘linked in’ to the kernel.
(I like module support, as it allows you to enable/disable specific Gadget modules.)

I think you can change the ROCK Pi S kernel commit id to 5e1be82eb296ba36f9f656a1b9ee9c2df7e5a1db in file linux-rockpi-s_4.4.bb since ROCK Pi S kernel in Radxa repo helps fixed the issue.

2 Likes

Hi @mattes. I’m glad you found it easy. I checked the commits in the radxa kernel repo for the rockpi-s and this has been solved there as @Stephen rightly pointed out. I’ll update the recipe to the latest commit and this should solve the problem.