Wireless module A8 is not working on Rock5b

Wireless module A8 is not working on Rock5b.
and the system is using ubuntu img. I noticed that some people mentioned that RTL8852BE requires a new driver to be installed, but I couldn’t find the driver instructions for installing RTL8852BE in the document. Using the “nmcli device” command only displays eth0 and lo, and I’m not sure if there is a problem with my Wireless module A8.
Please help.

Update, the wireless module A8 BTL8852BE cannot be identified by “lsusb” command when plugged into Rock5B, and the A8 cannot be identified when plugged into my laptop.
I plugged my laptop wireless card AC 3168 into the Rock5b and used the “lsusb” command to identify it.
Is there a problem with the RTL8852BE hardware?

do you have the antennas placed?
Also do this and check if bluetooth works

The fix for some Bluetooth Modules (A8, AX210, etc.):
sudo su
nano /etc/modprobe.d/blacklist.conf
then add these lines somewhere (at the bottom of the file is fine):

blacklist pgdrv
blacklist btusb
blacklist btrtl
blacklist btbcm
blacklist btintel

Then press Ctrl+X, then Y.
sudo apt install bluez or bluetooth – not needed to install since latest armbian version
systemctl status bluetooth CTRL+ C
systemctl start bluetooth
Then reboot .

I had some issues getting mine to work as well. I bought a random ax210 card off amazon. I tried a bunch and it didn’t work, then one time I turned the board back on and it just… worked and has since. I believe it was after updating all packages and firmware in the armbian config.

I set a blacklist according to your idea,
And I executed the following command, then reboot

root@rock-5b:~# apt-get update -y

root@rock-5b:~# apt-get install -y broadcom-wifibt-firmware intel-wifibt-firmware

root@rock-5b:~# systemctl status bluetooth

root@rock-5b:~# systemctl start bluetooth

After reboot, the following command is executed and returned without any response from the hciconfig

rock@rock-5b:~$ hciconfig

rock@rock-5b:~$ systemctl status bluetooth

● bluetooth.service - Bluetooth service

 `Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled; vendor preset: enabled)`

 `Active: inactive (dead)`

   `Docs: man:bluetoothd(8)`

rock@rock-5b:~$ systemctl start bluetooth

==== AUTHENTICATING FOR org.freedesktop.systemd1.manage-units ===

Authentication is required to start 'bluetooth.service'.

Authenticating as: rock,,, (rock)



rock@rock-5b:~$ hciconfig


kernel logs could not be captured from wireless. After I communicated with the manufacturer, the manufacturer asked me to send them back to him for analysis

AX210NGW WiFi Card WiFi6E 6GHz Tri-Band Network Card Bluetooth 5.3 intel M.2 NGFF

2021 New 1 Pair Universal Laptop IPEX MHF4 M.2 Internal Wireless WiFi Card Antenna for ngff 8260 8265 9260 9560 Adapter Aerial

This one is the one im using right now. (In case u want to try another module before going back to warranty etc).

What operative system are u on? Try on armbian.

It’s ubuntu now, and debian was the same before

Radxa oficial images have issues (or had issues before). Thats all Ive heard so try armbian if the same happens then u know for sure its bricked.

OK, A8 has been sent for warranty:smiley:

1 Like

Well it happens… I remember my wifi antenna breaking when I was trying to take it out… these things are somewhat sensitive.

Whether the WiFi antenna is connected or not has nothing to do with the card being recognized by the operating system.

The manufacturer replaced an A8. It’s working when installed on the 5B.
The original Wireless module A8 is supposed to be broken.


Did you try rtw89 driver (https://github.com/lwfinger/rtw89)?
I use moduleAX1800M with RTL8852BE on Rock 5B. I have had some problems with original driver in current kernel. But with rtw89 it works good.

I didn’t try you to say this driver.
but I used the same driver and replaced a hardware a 8 to work

1 Like

I was able to get the A8 wireless module working on my Rock 5B with the Ubuntu Jammy CLI image (https://github.com/radxa-build/rock-5b/releases/download/b36/rock-5b_ubuntu_jammy_cli_b36.img.xz) after installing and starting the WPA Supplicant service:
sudo apt install wpasupplicant

Before installing and starting WPA Supplicant, nmcli showed the wireless card, but it was marked unavailable. Once it was started, the card came online in nmcli and I was able to scan and connect to a wireless access point at my house.

1 Like