WIFI on Manjaro

After a very frustrating afternoon, I finally got Manjaro installed on my new Radxa Zero. Now, how do I get the wifi working?

uname --all
Linux radxa-zero 5.15.7-7-MANJARO-ARM #1 SMP PREEMPT Wed Dec 8 13:17:00 UTC 2021

When I do dmesg | grep firmware

Any suggestions?


Can you share the output of this command ?

uname -a
ls -la /usr/lib/firmware/brcm/ | grep radxa

I want to know which kernel is installed. The wifi firmware is already installed on the default image but from the screenshot it looks like it is failing to load or file not present.

I’m sorry I have to use images for my response.

https://github.com/LibreELEC/brcmfmac_sdio-firmware <= wget files from there

I have the same issue. Where do I need to store the files?

It should be /var/lib/firmware/brcm/

I used the one from you source only. I’ve tested out packages and it should have worked out of the box but i will test it once again this weekend.

I tested it. The firmware folder doesn’t exists, so I created one.

But it didn’t worked. The menu in the top where I can see the network doesn’t appear.
The function to connect the Bluetooth is shown, but not WIFI

I also have seen that the console on boot shows the following message:

Waiting for Network to be configured.

I don’t know it that has something to do with that problem. The WIFI settings is also showing the hint that it couldn’t found a adapter.

Can you guys point me to the image that you used ? I will test it tonight.

I use Manjaro Gnome who is on the Download page of the Radxa Zero: https://wiki.radxa.com/Zero/downloads

I also tested it with newer versions, but they don’t want to boot. Only this version booted.

That is an old image.

can you try something from here

While I am testing the lastest build from last night so I will check about wifi too.

Update I just installed the latest version and wifi works fine on default image no need to manually copy files.

1 Like

I tried an image from the link:




It boots up in Manjaro fine, but no wifi. I added my own wifi dongle.

When I run the command:

inxi -Fx

Under Network: I see:

Device-1: pwm-clock …
Device-2 dwmac driver: N/A …
Device-3 Realtek 802.11ac NIC type: USB driver: N/A bus-ID: 1-1.1:3

I can’t find the bcrm directory mentioned above. Any suggestions on how to even use my wifi dongle?

Did you tried any other images? Maybe your board wifi module damaged? Because many people uses that image and there is not any other same problem. I use exactly same image on uSD without any problem.

Wifi works fine on debian xfce image.

This is almost 2 months old. Try latest please.

Wifi Dongle model, chip model, etc ? Maybe config is not enabled by default for this chip.

@fapplin prob better to get releases from https://github.com/manjaro-arm/radxa-zero-images/releases
As that has the more up to date dev releases even if 21.12 was the last full release.

https://github.com/manjaro-arm/radxa-zero-images/releases/download/20220207/Manjaro-ARM-xfce-radxa-zero-20220207.img.xz is the latest if a dev release


what is the user name and password?

Does it not ask to set as think its manjaro:manjaro or root:manjaro
Guess cause its a dev version there is no initial setup
ps user:password

All images have oem setup on first boot…

Good luck and good night. :slight_smile:

1 Like

I feel like this problem is not about Manjaro but its about zero.
I have 2 boards in total. My first zero works great and there is no problem with wifi or anything.
I have the latest release of manjaro installed.

i got the second board yesterday and im dealing with wifi problem. I came to conclusion that its not the problem with the OS but it is with the zero board.

what doesnt makes sense to me is;
1st board > 4GB 64GB eMMC
2nd board > 4GB 128GB eMMC

I’ve checked the hardware on wiki and both uses same module

2GB or 4GB memory, it comes with AP6256 module

I wonder if they changed any firmware or any other setting / setup on the board ? its very much frustrating to deal with these problems in OS environment while the problem might exist on hardware…